Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => A13 => Topic started by: chjohn on October 23, 2019, 04:07:58 pm

Title: Can't boot from SD card
Post by: chjohn on October 23, 2019, 04:07:58 pm
I write my question in suppot@olimex.com but while they not answered, I decided to duplicate question in this forum.

message:
---------------------------------

Hi. I own A13-OLinuXino Rev.C (Made in Bulgaria 2012) with WiFi and Hynix RAM chip and LCD screen.

Default board load from NAND Arduino and work very well.

I try load from SD card use Linux OS, but I can't do this.

I use different images OS (from https://www.olimex.com/wiki/A13-OLinuXino and other place).

In UART1 shows following logs:

U-Boot SPL 2013.07-rc1 (Jun 20 2013 - 23:55:50)
Board: A13_MID
DRAM: 512MB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
SUNXI SD/MMC: 0
spl: mmc blk read err - 0
### ERROR ### Please RESET the board ###


For writing img to SD card I use Win32DiskImager-1.0 (Verify process succeeds)

I use difference DC source like 12V adapter (2.5A), USB, LiPO (direct to connector on board).

I use diffrence SD card (Kingston 16 GB microSDHC U1 and Smartbuy 32 Gb microSDHC U1).

And every time the same result.

I try write image direct to NAND, using LiveSuite, but program show "Image file invalid".

What can (necessary) be checked for successful boot loading from SD card ?

Best regards, John Ch.

---------------------------------

I also found that even an empty (fast format to FAT) SD card produces the same result when bord boot:
spl: mmc blk read err - 0

also I can't mount SD card in Arduino
UART1 show:

[  112.070000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 18,  RTO !!
[  112.080000] [mmc]: sdxc_request_done(L1118): In data read operation
[  112.080000] [mmc]: found data error, need to send stop command !!
[  112.090000] [mmc]: sdxc_send_manual_stop(L892): sdc 0 send stop command failed
[  112.100000] mmcblk0: unknown error 110 sending read/write command, card status 0x900
[  112.100000] end_request: I/O error, dev mmcblk0, sector 0
[  112.100000] Buffer I/O error on device mmcblk0, logical block 0
[  112.100000] end_request: I/O error, dev mmcblk0, sector 8
[  112.100000] Buffer I/O error on device mmcblk0, logical block 1
[  112.100000] end_request: I/O error, dev mmcblk0, sector 16
[  112.100000] Buffer I/O error on device mmcblk0, logical block 2
[  112.100000] end_request: I/O error, dev mmcblk0, sector 24
[  112.100000] Buffer I/O error on device mmcblk0, logical block 3
[  112.150000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 18,  RTO !!
[  112.160000] [mmc]: sdxc_request_done(L1118): In data read operation
[  112.170000] [mmc]: found data error, need to send stop command !!
[  112.170000] [mmc]: sdxc_send_manual_stop(L892): sdc 0 send stop command failed
[  112.180000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.190000] mmcblk0: error 110 sending status command, retrying
[  112.200000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.200000] mmcblk0: error 110 sending status command, retrying
[  112.210000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.220000] mmcblk0: error 110 sending status command, aborting
[  112.220000] end_request: I/O error, dev mmcblk0, sector 0
[  112.220000] Buffer I/O error on device mmcblk0, logical block 0
[  112.240000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 18,  RTO !!
[  112.250000] [mmc]: sdxc_request_done(L1118): In data read operation
[  112.250000] [mmc]: found data error, need to send stop command !!
[  112.260000] [mmc]: sdxc_send_manual_stop(L892): sdc 0 send stop command failed
[  112.270000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.270000] mmcblk0: error 110 sending status command, retrying
[  112.280000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.290000] mmcblk0: error 110 sending status command, retrying
[  112.290000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.300000] mmcblk0: error 110 sending status command, aborting
[  112.310000] end_request: I/O error, dev mmcblk0, sector 0
[  112.310000] Buffer I/O error on device mmcblk0, logical block 0
[  112.310000] end_request: I/O error, dev mmcblk0, sector 8
[  112.310000] Buffer I/O error on device mmcblk0, logical block 1
[  112.310000] end_request: I/O error, dev mmcblk0, sector 16
[  112.310000] Buffer I/O error on device mmcblk0, logical block 2
[  112.310000] end_request: I/O error, dev mmcblk0, sector 24
[  112.310000] Buffer I/O error on device mmcblk0, logical block 3
[  112.350000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 18,  RTO !!
[  112.360000] [mmc]: sdxc_request_done(L1118): In data read operation
[  112.360000] [mmc]: found data error, need to send stop command !!
[  112.370000] [mmc]: sdxc_send_manual_stop(L892): sdc 0 send stop command failed
[  112.380000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.380000] mmcblk0: error 110 sending status command, retrying
[  112.390000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.400000] mmcblk0: error 110 sending status command, retrying
[  112.400000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.410000] mmcblk0: error 110 sending status command, aborting
[  112.420000] end_request: I/O error, dev mmcblk0, sector 0
[  112.430000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 18,  RTO !!
[  112.430000] [mmc]: sdxc_request_done(L1118): In data read operation
[  112.440000] [mmc]: found data error, need to send stop command !!
[  112.450000] [mmc]: sdxc_send_manual_stop(L892): sdc 0 send stop command failed
[  112.450000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.460000] mmcblk0: error 110 sending status command, retrying
[  112.470000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.470000] mmcblk0: error 110 sending status command, retrying
[  112.480000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.490000] mmcblk0: error 110 sending status command, aborting
[  112.490000] end_request: I/O error, dev mmcblk0, sector 0
[  112.490000] end_request: I/O error, dev mmcblk0, sector 8
[  112.490000] end_request: I/O error, dev mmcblk0, sector 16
[  112.490000] end_request: I/O error, dev mmcblk0, sector 24
[  112.510000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 18,  RTO !!
[  112.520000] [mmc]: sdxc_request_done(L1118): In data read operation
[  112.530000] [mmc]: found data error, need to send stop command !!
[  112.530000] [mmc]: sdxc_send_manual_stop(L892): sdc 0 send stop command failed
[  112.540000] mmcblk0: error 110 sending status command, retrying
[  112.550000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.550000] mmcblk0: error 110 sending status command, retrying
[  112.560000] [mmc]: sdxc_request_done(L1114): smc 0 err, cmd 13,  RTO !!
[  112.570000] mmcblk0: error 110 sending status command, aborting
[  112.570000] end_request: I/O error, dev mmcblk0, sector 0


It seems to me that the SD slot is "broken", how check that ?

Maybe someone will advise what to do?

Thanks.
Title: Re: Can't boot from SD card
Post by: JohnS on October 24, 2019, 01:42:22 pm
You might like to try the correct spelling of their email :)

support not suppot

John
Title: Re: Can't boot from SD card
Post by: chjohn on October 24, 2019, 03:44:28 pm
Just in case checked, but in mail message address correct.

A mistake in this post.
Title: Re: Can't boot from SD card
Post by: chjohn on October 24, 2019, 04:15:45 pm
Try different images Linux, noticed that the start error description is different.

U-Boot SPL 2012.10-04265-gf355d60 (Dec 15 2012 - 13:08:48)
DRAM: 512MB
SUNXI SD/MMC: 0
spl: mmc blk read err - 0
### ERROR ### Please RESET the board ###


or

U-Boot SPL 2013.07-rc1 (Jun 20 2013 - 23:55:50)
Board: A13_MID
DRAM: 512MB
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2
SUNXI SD/MMC: 0
spl: mmc blk read err - 0
### ERROR ### Please RESET the board ###


After searching with hex-editor on SD cards, the text "gf355d60" or "2013.07-rc1", I fount it in the region of 0x6000 offset.

The eGON.BT0 signature is in the 0x2000 offset region.

It looks like the SD slot works, but still something prevents normal boot :(
Title: Re: Can't boot from SD card
Post by: LubOlimex on October 30, 2019, 01:26:27 pm
Board: "A13_MID" - this line seems very fishy.

How do you prepare the cards, what software or command do you use?

Try with these SD card Linux images, let me know the results with each of them:

1: ftp://staging.olimex.com/Allwinner_Images/A13-OLinuXino/2.legacy_images_kernel_3.4.x/A13_debian_34_90_WIFI_RALINK_GCC_GPIO_X_I2C_100KHz_UVC_TS_FTDI_3G_video_accell_release_10.7z

2: ftp://staging.olimex.com/Allwinner_Images/A13-OLinuXino/2.legacy_images_kernel_3.4.x/A13_debian_34_90_mainline_u-boot_release_11_3.torrent

3: ftp://staging.olimex.com/Allwinner_Images/A13-OLinuXino/1.latest_mainline_images/bionic/images/Armbian_5.79_Olinuxino-a13_Ubuntu_bionic_next_5.0.9_desktop.zip