Olimex Support Forum

Microcontrollers => PIC => Topic started by: lucari on December 16, 2012, 02:42:49 pm

Title: Building code for PIC-MAXI-WEB
Post by: lucari on December 16, 2012, 02:42:49 pm
Hi,

I'm having problems building the software for the PIC-MAXI-WEB. I've downloaded the latest stack from this site (the one with the Microchip stack). I'm using MPLAB-8 with the 3.37 C compiler. I've also downloaded the p18f67j60.h file. Apart from tweaking a few directory names, the 'Build-All' run without errors.

However, when I download to the board using a PICKIT-2, nothing happens. The LCD doesn't display anything and after a few minutes, the relays click and that's it. If I install the 'Pre-built' image, it all works ok.

I have noticed that the processor is a 18F97J60 and the build doesn't use the replaced .h file.

Everything looks ok, it just doesn't do anything. Do I need a modified p18f97j60.h file instead ?

Thanks

Richard

** Updated - I've run the PICKIT-2 as a debugger and tried again. It seems to start-up normally but then resets itself. If I go slowly, it does display something on the LCD. **
Title: Re: Building code for PIC-MAXI-WEB
Post by: lucari on December 18, 2012, 12:14:08 am
I seemed to have sorted this out myself (with Google). The working header file can be found on the Microchip forum in the thread: http://www.microchip.com/forums/m544220-print.aspx (http://www.microchip.com/forums/m544220-print.aspx).

The file itself is is at http://www.microchip.com/forums/download.axd?file=0;570137 (http://www.microchip.com/forums/download.axd?file=0;570137) (I'm not sure if this will work). It needs to be renamed from .txt to .h once downloaded.

If possible, could the wrong file on product page https://www.olimex.com/Products/PIC/Development/PIC-MAXI-WEB/ (https://www.olimex.com/Products/PIC/Development/PIC-MAXI-WEB/) be replaced with this one.

I've copied this file onto my pc and the 5.31 Demo Stack builds and runs without problems.

Richard
Title: Re: Building code for PIC-MAXI-WEB
Post by: LubOlimex on December 18, 2012, 03:23:06 pm
Hey Richard,

Glad you solved the problem! I updated the web page with the header for PIC18F97J60 found by you. Thank you! By the way is there a reason to use C18 v3.37 compiler instead of more recent ones?

Best regards,
Lub/OLIMEX