Olimex Support Forum

Others => Biofeedback - EEG, ECG, EKG => Topic started by: gabe on January 20, 2016, 07:39:27 am

Title: EEG-SMT noise when trying EKG
Post by: gabe on January 20, 2016, 07:39:27 am
I followed the manual exactly and am trying to get a simple EKG reading on any one of the 3 suggested programs.  BrainBay, ElecGuru, and OpenVibe all detect and show the oscilloscope of the device successfully.  I am using a battery-powered (not plugged in) laptop to power the device.



What is the simplest way to get a noise-less EKG reading / what screenshots in what programs under what conditions would help diagnose this issue?  I assume this is the easiest test to make sure all the hardware is working before I dive into weaker signals like EMG/EEG.
Title: Re: EEG-SMT noise when trying EKG
Post by: gabe on January 23, 2016, 09:03:04 pm
I uploaded a series of images to http://imgur.com/a/f7ZEw (http://imgur.com/a/f7ZEw). All electrodes were plugged in for the duration of this and "connected" just means to my body or not.

The raw oscilliscope is at the top right, the filtered (pass 0.5hz-50hz, notch on 50hz and 60hz) is at the bottom right, and the raw spectrum is at the bottom left.  Please let me know how I can reduce the noise and get a readable EEG.  Once again, I am powering this from my laptop battery and not touching anything but the electrodes when taking these readings. 
Title: Re: EEG-SMT noise when trying EKG
Post by: LubOlimex on January 26, 2016, 12:21:15 pm
Hey,

The fact that there is a flat line when nothing is connected is kind of good news. The readings you get are completely messed up, however. It looks like the DRL doesn't make any contact at all.

Your BrainBay sketch seems very complicated for such a simple setup. You just need two elements. Did you notice the description in the user's manual:

1) Click Load Design and import a sample project from folder Test_Elements (for example modeeg_test.con or 2chn_test.con, but feel free to check others also)

2) From Option -> Device manager change the COM port to the COM port EEG-SMT is assigned to and the baud rate to 57600 (you can check/change the COM in Windows Device Manager in Ports section, the device is recognized as USB Serial port (COM X))

3) Connect the electrodes to the EEG-SMT (!!! The one connected to DLR must be passive electrode)

4) Place the DLR electrode (feedback) on your leg (you can also try to hold this one firmly in your palm for the ease of testing) and the other 2 electrodes on your hands under the elbow - best idea is to place them symmetrically to each other and then on a place where the skin is softer.

5) Click Play (F7)

If there is still problem test what would happen if you use CH2+/- for the electrodes. You always need good contact with the DRL or you might receive only noise.

Also make sure that the electrodes are fully plugged in the audio jacks.

Best regards,
Lub/OLIMEX
Title: Re: EEG-SMT noise when trying EKG
Post by: gabe on January 31, 2016, 06:30:06 am
My Settings
(http://imgur.com/0vwIWq2.jpg)
(http://imgur.com/EyAhyRb.jpg)
(http://imgur.com/EZ7lwpf.jpg)
(http://imgur.com/hu1oTeN.jpg)

When everything is disconnected
Setup: http://imgur.com/5aUSkVU (http://imgur.com/5aUSkVU)
Results: http://imgur.com/Un9ZGRf (http://imgur.com/Un9ZGRf)

Noise on channel 1 when everything is connected but not touching me
Setup: http://imgur.com/i6jbRUx (http://imgur.com/i6jbRUx)
Results: http://imgur.com/YzaEIY0 (http://imgur.com/YzaEIY0)

Noise on channel 2 when everything is connected but not touching me
Setup: http://imgur.com/mxnPW8P (http://imgur.com/mxnPW8P)
Results http://imgur.com/QOsLPhq (http://imgur.com/QOsLPhq)

When I connect both arms to channel 1 but leave DRL not connected (note, other arm is connected), I get straight lines
http://imgur.com/SlmZF0r (http://imgur.com/SlmZF0r)

When I connect both arms to channel 2 but leave DRL not connected (note, other arm is connected), I get noise (weird?)
http://imgur.com/UlxbYov (http://imgur.com/UlxbYov)

When I connect to channel 1 with DRL in palm (note, other arm is connected), I get noise
http://imgur.com/gmtm7E9 (http://imgur.com/gmtm7E9)

When I connect to channel 2 with DRL in palm (note, other arm is connected), I get noise
http://imgur.com/nPJ2DXq (http://imgur.com/nPJ2DXq)
Title: Re: EEG-SMT noise when trying EKG
Post by: research on January 31, 2016, 02:15:50 pm
I think you need to set the baud rate (bits per second) to 57600 in order to make it work properly.

good luck!
Title: Re: EEG-SMT noise when trying EKG
Post by: gabe on February 01, 2016, 05:30:21 am
i haven't done that on that settings screen since all the screenshots in the quick start show 9600 and only to set it higher on brainbay, but it's worth a try ...
Title: Re: EEG-SMT noise when trying EKG
Post by: gabe on February 01, 2016, 07:59:40 am
i just tried adjusting the driver to 57600 and i get the same results.  i think the biggest inconsistency apart from the general noise is when both CH1 electrodes are attached to my arms with the DRL plugged in and hanging, the result is close to a flat line 0, but when both CH2 electrodes are attached to my arms with the DRL plugged in and hanging, i get noise.  any more help here?
Title: Re: EEG-SMT noise when trying EKG
Post by: research on February 01, 2016, 12:01:31 pm
Well, afaik the DRL should be connected. Quote from http://www.biosemi.com/publications/artikel7.htm as referred to in the schematic doc from olimex (https://www.olimex.com/Products/EEG/OpenEEG/EEG-SMT/resources/EEG-SMT-SCHEMATIC-REV-B.pdf):

Quote... A DRL circuit reduces the common mode voltage by driving U0 (see Fig. 2.) actively to the potential of the amplifier common (MettingVanRijn et al,. 1990). A DRL, in addition, protects the patient from the consequences of amplifier defects because a series resistor in the circuit (R0 in Fig. 2) limits the maximum current through the ground electrode to a safe level. The common mode suppression of a DRL circuit increases with decreasing frequency. Consequently, the DRL circuit compensates for the decreasing CMRR of the instrumentation amplifier in Fig. 2 at low frequencies. In our view, a DRL should be used in every biomedical recording system for interference suppression and patient safety. ...


And from the schematic board description:

QuoteImportant usage instructions for the DRL.
If you only want to use one channel, never let the other channel float.
Always connect the unused terminals to V_REF, or the DRL will not work properly.


Thus, in total I would infer that all electrodes should be connected to measurement sites or reference points in order to get good and safe measurements. Especially, the DRL needs to be connected, also for safety reasons.
Title: Re: EEG-SMT noise when trying EKG
Post by: LubOlimex on February 03, 2016, 10:33:56 am
Hey,

The last two tests are the only properly conducted ones which should yield expected result (yet, the results doesn't appear good at first, but this might be related to improper graph ranges):

QuoteWhen I connect to channel 1 with DRL in palm (note, other arm is connected), I get noise
http://imgur.com/gmtm7E9

When I connect to channel 2 with DRL in palm (note, other arm is connected), I get noise
http://imgur.com/nPJ2DXq


The rest of the tests are somehow improper.

I would recommend you to perform the same two tests (as the one quoted above) but instead of placing the electrodes to the hands - place them on the head - keep them just above the temples of your head. Again keep the DRL in your hand. This would show if the problem is in the ranges defined in the software.

I would also recommend you to test with the electric guru software.

The strange thing is that both channels show improper data. This is something I haven't seen in a while - if there is a hardware problem it is usually related to the audio jack of one of the channels, but both channels showing wrong data - either a misuse or hardware problem of more serious magnitude. It is hard for a board with such a serious problem to leave our facilities since each EEG-SMT gets tested on software level - a technician performs an EKG test on each channel and calibrates the amplification.

Let me know how it goes.

Best regards,
Lub/OLIMEX