Olimex Support Forum

Others => KiCAD => Topic started by: olimex on March 18, 2015, 08:31:01 am

Title: Footprint Editor do not allow to add copper!
Post by: olimex on March 18, 2015, 08:31:01 am
today we found new feature missing - when you make new component foot print you can add only pads but not copper drawings which limits the footprint editor to just components, but what if I want to make module with some connections between the pads? now this option is disabled (gray).
Title: Re: Footprint Editor do not allow to add copper!
Post by: engidea on July 01, 2015, 03:40:31 pm
You can draw a line and then change the line layer to a copper layer (it will warn you)

The line can be "thick" or you can kind of "fill up" using a few lines

There are probably some issues when "flipping" the component....

Yes, not perfect but it is mostly there...