Olimex Support Forum

Microcontrollers => PIC => Topic started by: mmayr@mmm-it.com on October 31, 2014, 05:31:30 PM

Title: PIC -P67J60 Test Card Power Supply Question
Post by: mmayr@mmm-it.com on October 31, 2014, 05:31:30 PM
Hello,

I would like to ask if it is possible to use the PIC P67J60 Testcard instead of with a 9V DC Power Supply with a 12V Power Supply ?

The reason is the following - I need a 12V DC for a LCD Module 1602A and if I could use the 12V Power for both I could pick the 12V from the card directly for the LCD too ?

The MC34063A supports up to 40V DC input but I'm not sure about the DB104S?

So the question is : Is there any risk to connect to 12V DC ? Since at OLIMEX the Power Supplies sold are typically 12 V or 5V DC ... I Wonder if it should be a 12V DC Power supply to be used ?

Best regards



Title: Re: PIC -P67J60 Test Card Power Supply Question
Post by: JohnS on October 31, 2014, 07:18:42 PM
It's not a risk I'd take.

John
Title: Re: PIC -P67J60 Test Card Power Supply Question
Post by: MBR on November 02, 2014, 09:32:52 AM
The MC34063A supports up to 40V DC input but I'm not sure about the DB104S?

According to datasheets, the DB104S is rated 1A 400V (see http://www.farnell.com/datasheets/1441677.pdf (http://www.farnell.com/datasheets/1441677.pdf)). Even the capacitor C11 near the MC34063A is rated 25V. So there, theoreticaly, should be no problems when running on stabilised 12V DC.
Title: Re: PIC -P67J60 Test Card Power Supply Question
Post by: mmayr@mmm-it.com on November 03, 2014, 04:23:50 PM
Hello, thanks for your replies,

I took the risk and it works ... but I came to another problem now, I would like to use a 12V DC LCD Display in the same circuit and my question is :

Since the Power Input is for AC too, when I only use the board on DC, may I connect the board with Gnd connected to Gnd"1" of your schematics ?

Because when I pick the 12V DC for the LCD Display 1602A as follows:


Connected 12V to Vss of the LCD
Connected 12V to K
Connected K to Poti (LCD brightness) and to V0 and other side of the Poti to Gnd
Connected Gnd to VDD

without having the GND of the 12V connected to the GND of the Olimex board the board doesn't start up :(

If I disconnect my 12 V from the LCD it starts up normally again ....

Any ideas or help?

Thanks a lot ...