Olimex Support Forum

Microcontrollers => MSP430 => Topic started by: mattse_de on July 30, 2014, 10:19:28 pm

Title: MSP430-JTAG-ISO-MK2 no target power and other problems
Post by: mattse_de on July 30, 2014, 10:19:28 pm
Hello,

i have a project with a msp430F2418
For this reason i looked for programmer and found the Olimex one.

But i have problems to connect to the target. Even the target power is not displayed. All otther too.
No target typ. I examined the wiring, all OK. I would be happy, if it would display the power. Only if it switches to internal, it shows it.
The target power comes to the 14-pin connector of the programmer, no display.

Any idea how to connect?

Thanks

After i had all wires controlled, i think the Programmer is not working. It is a expensive test and i thought olimex is reading in his own forum. OK, holidays.
Or the cpu is shit. I believe i throw both out of the window and mark this chapter of test phase as failed.
Title: Re: MSP430-JTAG-ISO-MK2 no target power and other problems
Post by: mattse_de on August 26, 2014, 10:29:56 am
Ok, may be i described my problem in a wrong way. The target-power is not a problem any more.
It was a wrong description of the signal wire.

But i can not connect to the target. It can not be found. What i had not said is, on my self made board i use a mini 10 pin socket. So i have to convert from 14 to 10 pin. I have the 20 to 10 pin (https://www.olimex.com/Products/ARM/JTAG/ARM-JTAG-20-10/) and i made a little pcb to route the wires like described in your schematics. The whole lenght is about 15cm.

I checked all wires from the debuger to the MSP-board. It is all OK.

My personal programmer, who writes the software for the MSP-board, uses a j-link and soldered the wires directly to the board. This version functions.

Hi Olimex, can you make adapters, may be universal (20, 14 to 10 pin)? That would be nice.