Olimex Support Forum

Others => Biofeedback - EEG, ECG, EKG => Topic started by: jyviko on October 25, 2012, 03:21:46 pm

Title: SHIELD-EKG-EMG too sensitive!
Post by: jyviko on October 25, 2012, 03:21:46 pm
Hi all,

I am trying to setup a 2-channel EMG acquisition with two stacked SHIELD-EKG-EMG and an Arduino Uno. The problem I am facing is that the shield seems to be extremely sensitive to environmental artefacts that render a complete acquisition impossible. For instance when I am touching/moving the female jack on the board I get huge signal readouts (http://i1141.photobucket.com/albums/n584/jyviko/Example01.jpg)(http://i1141.photobucket.com/albums/n584/jyviko/Example02.jpg). Even when I am blowing air on top of the board I can see huge drifts in the signal.
 I managed once to get a good signal but since then I was not able to reproduce it (http://i1141.photobucket.com/albums/n584/jyviko/Example03.jpg). 


I am using the following electrodes: (http://products3.3m.com/catalog/au/en005/healthcare/medical/node_GS9327YX1Hgs/root_D58K9TX3VWgv/vroot_RB2X68D0SCge/bgel_RNQ0VKC2F1bl/gvel_HK4CVCBCDRgl/theme_au_medical_3_0/command_AbcPageHandler/output_html).

I would appreciate any help.

Thank you in advance,
Jiko
Title: Re: SHIELD-EKG-EMG too sensitive!
Post by: LubOlimex on October 26, 2012, 09:51:35 am
Hello Jiko,

How did you set the jumpers up? Did you close the REF_E jumper of SHIELD-EKG-EMG?

Best regards,
Lub/OLIMEX
Title: Re: SHIELD-EKG-EMG too sensitive!
Post by: yo9bxe on December 30, 2012, 07:27:44 pm
Hello dear friend ,
We purchased a platform EKG EMG. I do not know where to place the sensors, the exact location.
I do not know how to make settings at ElecGuru.  The manual details are sketchy.  A beginner can not handle.
It works but I do not correctly. My students want to buy but were disappointed operating. I use a Arduino Duemilanove about 1 year .  It works correctly. Can be found a detailed video.
Happy New Year 2013 !  Thanks !  Nelu , teacher at Children  Palace Robotics Club
Title: Re: SHIELD-EKG-EMG too sensitive!
Post by: Stan12 on January 01, 2013, 02:22:58 am
Quote from: yo9bxe on December 30, 2012, 07:27:44 pm
Hello dear friend ,
We purchased a platform EKG EMG. I do not know where to place the sensors, the exact location.
I do not know how to make settings at ElecGuru.  The manual details are sketchy.  A beginner can not handle.
It works but I do not correctly. My students want to buy but were disappointed operating. I use a Arduino Duemilanove about 1 year .  It works correctly. Can be found a detailed video.
Happy New Year 2013 !  Thanks !  Nelu , teacher at Children  Palace Robotics Club

Hi, if I understand it right, you are trying to use the board for ECG registration. In this case,
as for rubber bands electrodes placement I'd suggest to put L on left hand forearm (like, 3-4 inches away from hand), R and D electrodes on right forearm close to each other. ElecGuru software should be set up like this:
Preferences/Machine/RS232EEG
Preferences/SerialPort - select virtual serial port you should see in the list after your Arduino board being connected, usually smthng like COM3 or higher
Preferences/Trace(waveform) Height scroller to the rightmost position.
All other settings are not relevant to ECG, leave them alone.
To start registration click 'Green traffic light' icon (the topmost on the left-side vertical icons bar).


Provided front-end application is a little bit in too much of pre-release condition, so you could easily create your own using, f.e. Processing language.
Happy New Year! :D
Title: Re: SHIELD-EKG-EMG too sensitive!
Post by: LubOlimex on January 08, 2013, 10:17:18 am
Thank you, Stan12!

yo9bxe, please check Stan12's post here about SHIELD-EKG-EMG and Arduino Duemilanove: https://www.olimex.com/forum/index.php?topic=572.0#msg2180 (https://www.olimex.com/forum/index.php?topic=572.0#msg2180)

Best regards,
Lub/OLIMEX