Olimex Support Forum

Others => Biofeedback - EEG, ECG, EKG => Topic started by: casesunny on October 14, 2013, 11:04:22 pm

Title: Flat line in BrainBay
Post by: casesunny on October 14, 2013, 11:04:22 pm
Hi there,

I just purchased an EEG-SMT with 4 active electrodes and one passive electrode.
I followed the procedures on the user manual step by step; however, I cannot get signals.
There are couple of points that I may have made mistakes. Could someone help me take a look?

1. I downloaded and installed the latest FTDI-VCP from the website. The name is CDM 2.08.30 WHQL Certified, is this the right one? And it is updated automatically, it seems not necessary to locate ftdibus.inf myself.

2. I cannot download ElecGuru now. The link does not work for me. So I tried BrainBay and OpenVibe as the tutorial told me. I tried to use design "2chn_test.con" in BrainBay; however, there was only a flat line along "-256uV" when I connected electrodes and click "play". I tried different placement of electrodes: one channel and DRL, two channels and DRL, AE and PE. The results were always a flat line along -256uV. I even tried connect CH1 and DRL. I thought it could be zero, but nothing changed.

Could someone help me point out my possible mistakes? Thank you very much!
Title: Re: Flat line in BrainBay
Post by: blackcoat on October 15, 2013, 03:48:59 pm
Hi Casesunny,

A few basic things to check:

Did you check the device settings? Make sure to set to 57600 bits per second.

Also, remember the COM port that is set in the device settings, so that you can set the same COM port in, for example the brainbay EEG instrument, or in the the openVibe acquisition server. In the openVibe server also make sure to "connect" and "play".

Shout if it does not make enough sense and I'll try to give more information (and to the more seasoned users, please check my answers, I am also a newbie - just trying to give a quick answer . . . )

Rob
Title: Re: Flat line in BrainBay
Post by: LubOlimex on October 16, 2013, 10:31:14 am
Hey casesunny,

I can upload the ElecGuru to another place if the following link doesn't work for you: https://www.olimex.com/Products/EEG/OpenEEG/EEG-SMT/resources/ElecGuru40.zip (https://www.olimex.com/Products/EEG/OpenEEG/EEG-SMT/resources/ElecGuru40.zip).

It is important that the passive electrode is the one used for DRL and you are sure it makes a good contact with the skin (or you have a good grip of it if you hold it in the hand).

Try with just 2 active electrodes connected to CH1+ and CH1- and a passive electrode to the DRL.

Remember to select the proper COM port (as seen in "Windows Device Manager") in the software tools you use. It is a very good idea to lower the "Latency Timer" of the virtual COM port.

Best regards,
Lub/OLIMEX
Title: Re: Flat line in BrainBay
Post by: LubOlimex on November 08, 2013, 01:24:35 pm
Please also try with these drivers: https://www.olimex.com/Products/_resources/FTDI_drivers_2.04.06.zip (https://www.olimex.com/Products/_resources/FTDI_drivers_2.04.06.zip).

Best regards,
Lub/OLIMEX