Olimex Support Forum

Microcontrollers => MSP430 => Topic started by: max_design on July 15, 2013, 03:16:01 pm

Title: MSP430-JTAG-ISO-MK2 troubles in entering Mass Storage Mode and Stand Alone Mode
Post by: max_design on July 15, 2013, 03:16:01 pm
Hello, I'm having some trouble in enter Mass Storage or Stand alone mode in a MSP430-JTAG-ISO-MK2. I need to enter these modes of operation for on-field programming of devices using MSP430 core. I've noticed that the green status LED is always blinking. After installing the drivers and updated the DLLs and firmware, the interface is recognized and I'am able to use the debugger interface in Debugger Mode but the green status LED is always blinking. In this mode I'm able to programming devices, debug devices and the interface tell me the amount of current needed by the device so in this mode all seems to work fine except for the green status LED that continue to blink.

I'm not able to enter Mass Storage Mode or Stand Alone Mode. Every action I take the interface always return in Debugger Mode. Even if I disconnect the USB port and feed the device with 12V in the 12V jack, selecting a mode other than Debugger Mode will always return the device in Debugger Mode. The green status LED is always blinking even in Debugger Mode. At sturtup the display shows:

  Debugger
  MCU UNKNOWN
  Power EXT
  Vt 0.0  It  0u
  MODE

Please I need help. Kind regards.
Title: Re: MSP430-JTAG-ISO-MK2 troubles in entering Mass Storage Mode and Stand Alone Mode
Post by: max_design on July 16, 2013, 04:33:45 pm
we finally have found the problem: the internal microSD card was gone out of the slot probably due to an accidental hit. Now with the SD card properly inserted we are able to enter all the three different modes of operation. The solution was suggested by Lub via private mail messaging. Thanks for the support.