Olimex Support Forum

Microcontrollers => PIC => Topic started by: 8art-5imson on June 17, 2013, 01:50:11 am

Title: Pic web restore
Post by: 8art-5imson on June 17, 2013, 01:50:11 am
Hi
I have managed to mess up my pic web Rev C by holding button down for longer than 4 seconds erasing the flash. So I down loaded modified stack 5.42 and flashed it to pic web with a pickit 3 via map lab 8.73. I have pluged it into serial port and checked network settings ect (it's at 192.168.0.30) but when I go to that page nothing is there ? Somtimes while it is trying to connect if I reapeatadly press reset I get the a sort of web page in plain text no red olimex logo and just ? Marks where button, led, temp are ???  Is 5.42 compatable with my rev c board ?  If not where can I download a compatable .hex file from, I don't remember what version was originally on it. But that worked fine, until I messed it up! Please help
Chris

Title: Re: Pic web restore
Post by: Stanimir5F on June 17, 2013, 03:31:24 pm
Hi Chris!

The demo on the web (5.42) is designed exactly for PIC-WEB rev.C.
Unfortunately I have not the problem that you describe so I can't tell you exactly what to do. Yet I have a clue what may cause the problem.

Are you using the right version of the compiler to build the project? It is built with PIC18 C Compiler 3.40.

The demo project on the web is based on the Microchip Solution library and when you try to install it there is a warning message at the beginning about relation between IDE <--> compiler versions. Check this screenshot for details (http://i.imgur.com/5slbVPh.png). So if you use another compiler I can recommend you to install the latest version of MPLAB/MPLABX.

If this doesn't help you try to program the board with the prebuilt hex file inside the demo project and see if you still have the same problem.

Stan, Olimex
Title: Re: Pic web restore
Post by: 8art-5imson on June 18, 2013, 10:21:26 am
Many thanks. I tried ver5.00,5.31,and 5.42 and all of them seemed to do slightly different things but none worked, than after reading the manual properly, realised that I had to reload the web page as it was not part of the firmware. So I am now all back to where I started, and feel a bit dumb for missing such an obvious thing. I suppose in doing this I have learned a bit more about this board! Thanks Chris.