Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => A10s => Topic started by: koray.duran on June 12, 2013, 12:30:02 am

Title: Uart Problem
Post by: koray.duran on June 12, 2013, 12:30:02 am

I can't use uart ports of A10s execpt uart0 which is for debugging. Read and write permmissons are given to all ttyS files and when i try to use other 2 ports i have an error. "The serial port can not be opened for an unknown reason."

Do you have any idea ?
Title: Re: Uart Problem
Post by: hno on June 12, 2013, 02:30:46 am
Is the other UARTs activated in your script.bin?
Title: Re: Uart Problem
Post by: koray.duran on June 15, 2013, 12:38:59 pm
I've tried to convert bin file which i download from board to fex but without success.
Does anyone has it in fex?
Title: Re: Uart Problem
Post by: David Goadby on June 15, 2013, 02:47:24 pm
If you look in the boot sector the unencoded .fex files are there. I quick look at the HDMI version shows these relevant extracts:

uart_debug_port = 0
uart_debug_tx = port:PB19<2><1><default><default>
uart_debug_rx = port:PB20<2><1><default><default>

uart_used = 1
uart_port = 0
uart_type = 2
uart_tx = port:PB19<2><1><default><default>
uart_rx = port:PB20<2><1><default><default>

uart_used = 1
uart_port = 2
uart_type = 2
uart_tx = port:PC18<3><1><default><default>
uart_rx = port:PC19<3><1><default><default>

uart_used = 1
uart_port = 3
uart_type = 2
uart_tx = port:PG09<3><1><default><default>
uart_rx = port:PG10<3><1><default><default>

Although I have not tried them yet it seems that ports 0, 2 & 3 are configured by default.

If you want log-in using the other serial ports you should check the settings in /etc/inittab and there should be an entry in /etc/securetty too.

If you run: setserial -g /dev/ttyS[0123] you should see the UART's and current settings.

I will try to look at this myself a little later in case there are some quirks lurking..

David Goadby