ARM-USB-TINY-H Init com fail on JTAG launcher

Started by aherve, March 04, 2024, 02:22:06 PM

Previous topic - Next topic


Hello there !

I'm having a hard time here trying to install and use ARM-USB-TINY-H on a Windows 10 PC.

I used Zadig 2.1 to install drivers (for interface 0 and 1) and they both appears in device manager. No issues installing both drivers. I followed step by step instructions on user's manual.

My problem here is that when i open my launcher to JTAG my franking machine, we have a step "Init com" aka communication with ARM-USB-TINY-H.

I then have a quick CMD pop up appearing with : "Error: unable to open ftdi device : 2"

I also tried to connect it to an other computer with Windows 10 too, and i'm getting the same result.

If anyone can help me out !

I can give more informations if need

Thank you !


Probably discrepancy between driver used and driver required by software (aka "Init com"). It is entirely possible to have software that requires different driver.

What is this "Init com" step? Can you describe what it does or maybe show us the contents? Is it possible that your software requires different drivers?

Did you try with bare OpenOCD and command line instead of "Init com"? As described in "3.4.1 Starting OpenOCD GDB server via FTDI drivers" of the manual.
Technical support and documentation manager at Olimex


Hello !

To explain what "init com" is, it's simply the communication between arm usb tiny h and the franking machine.

I tried the OpenOCD and line command and i get this result (i also added the cmd error when i use my launcher) :cmd test


1) In the first screenshot the problem is not in the debugger or the driver. It is properly recognized. It appears like wrong hardware connections.

What is your target? How is the JTAG connected to it?

2) The second screenshot is ancient OpenOCD version 0.1.0, if you are using the ancient OpenOCD, you probably need ancient drivers. Try the FTDI drivers, they require manual installation and pointing. First uninstall the zadig drivers. Here you can find very old drivers:

Technical support and documentation manager at Olimex


The target is a franking machine, the connection is actually like this :

 Board of a franking machine connected to a FP E204470 D1 94V-0 board connected to the ARM-USB-TINY-H probe connected to the computer by the front usb port.

I can't install those FTDI drivers. It says that the file is damaged of falsified.


Yeah they are old, before Windows invented signed drivers and driver signature enforcement. You need to disable temporarily Windows "Driver Signature Enforcement", install the driver for the tool, and after confirming it works, restart the PC to re-enable the "Driver Signature Enforcement". Disabling the driver signature enforcement differs between different Windows versions but it is usually like that:

1.1. Click the Start button and select Settings (do not confuse it with Start Menu Settings).
1.2. Click Update and Security.
1.3. Click on Recovery.
1.4. Click Restart now under Advanced Startup.
1.5. Click Troubleshoot.
1.6. Click Advanced options.
1.7. Click Startup Settings.
1.8. Click on Restart.
1.9. On the Startup Settings screen press 7 or F7 to disable driver signature enforcement.
1.10. After disabling the enforcement, DO NOT RESTART your PC, else you would have to start from step 1.1.

If you have problems with disabling "Driver Signature Enforcement", notice that there are many resources online on how it can be done. My advice is to use the manual method without permanent disable, just temporary.

After you have managed to disable the signature enforcement, install the driver manually (point Device Manger to the file inside) and test if it works. Notice that if you change the USB port, you would need to re-disable the enforcement and re-install the drivers so make sure to keep the same USB port that you are going to use long term.

You might also give a try to these drivers:
Technical support and documentation manager at Olimex


After installing et testing every kind of drivers you gave me, the result is still the same sadly  :(

I also tried to disable firewall but still same result
The thing that i don't understand is that we have an other computer with windows 10 and the same settings/hardware and it works for them. They installed it with Zadig too.


Oh interesting, maybe it is different kind of USB port then? Maybe this computer has only USB 3.0 ports? Maybe try a splitter?
Technical support and documentation manager at Olimex


A little update here !

We managed to get it working by reinstalling drivers from zadig 2.8 and update our sequences from our JTAG launcher to be in alignment with everything else !

Works perfectly fine now  ;D

Thank you !