Welcome, Guest

Author Topic: Olinuxino micro doesn´t boot  (Read 4826 times)

ecolomato

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Olinuxino micro doesn´t boot
« on: November 16, 2012, 11:28:27 AM »
Hi,
I´m trying to boot Olinuxino micro for the first time, and the board seems to auto reboot all the time. It doesn´t ask for login via telnet anytime (doesn´t reach that point).
The messages I get in hyperterminal are as follows (copy and paste):

HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLFCecurity Framework initializedlowmem  : 0xc0000000 - 0xc4000
Mount-cache ha
PowerPrep start initialize power...ctor  : 0x
co
    mo

les : 0xbf000
Battery Voltage = 0.68V MB)
Kernel command lin
No battery or bad battery                                       detected!!!.Disaes)   
pid_max: default: 32768 minimum: 301xfde
      .text : 0xc0026000 - 0xc0
bling battery                                   voltage measurements./r/nLLCMay: 0xc0356000 - 0xc0381a00   ( 175 kB)cache hash table entries: 8192 (order: 3,
11 201215:26:EMI_CTRL 0x1C08404init_ddr_mt46v32m10Frac 0x92926192re ver
        RCU-based detection of stalled CPUs is disabled.yt
LLLLLLLFCLJUncompressing Linux... done, booting the kernel.   Verbose stalled-CPUs detection is disabled.vice 80x
Memo
Linux version 2.6.35.3_OLinuXinoR4 (hehopmajieh@hehopmajieh-office) (gcc versionmy device 80x30ay loop... 226.91
Virtual kernel
console [ttyAM0] enabled     
No b
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)etected!!!.
console
regulator: mmc_ssp-1: fast normal> 3575
Memory: 64MB = 64MB total
regulator: mmc_ssp-2: fa
Memory: 57208k/57208k available, 8328k reserved, 0K highmemr-1: fast normalt: 32768 minimum: 301   
regulato
regulator
Virtual kernel memory layout:ork initializedL 0x1C08404ini
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)12ator: vddd: 8
HTL
r
i.MX IRAM pool: 28 KB@0xc48
    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)LLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLL
    DMA     : 0xfde00000 - 0xffe00000   (  32 MB)amily 16pmajieh@hehopmajieh-office) (
PowerPrep s
    vmalloc : 0xc4800000 - 0xf0000000   ( 696 MB): power-t
Battery Voltage = 1.43V7.1 20120421 (pr
    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)                      detected!!i.MX IRAM pool: 2
    modules : 0xbf000000 - 0                           
CPU: Testing write buffer coherency: ok writebackM
Memory: 57208k/5720
Battery
regulator: core version 0.5 zonelists in Zone order, m
NET: Registered protocol family 1616256         detected!!!.Disa:v5T
regulator: vddd: 800 <--> 1575 mV at 1550 mV fast normaland line: noinitrd console=ttyAM0,115200 root=/dev/mmcbl
regulator: vdddbo: 800 <--> 1575 mV fast normal00   ( 896 kB) iMX233-OLinuXino low cost boar
a
regulator: vdda: 1500 <--> 2275 mV at 1750 mV fast normal: -2, 1024 bytes)m10Frac 0x92926192                     
regulator: vddio: 2800 <--> 3575 mV at 3300 mV fast normal, 32768 bytes)x... done, booting the kernel. lowmem  : 0xc
regulator: overall_current: fast normal entries: 4096 (order: 2, 16384 bytes)R
regulator: mxs-duart-1: fast normalgcc version6 MB)rootwr=
Memory: 64M
regulator: mxs-bl-1: fast normal    .i
Memory: 57208k/57208k ava
regulator: mxs-i2c-1: fast normalREEMPT Mon May 21 10:27:52 EEST 2
regulator: mmc_ssp-1: fast normal kernel memory layout:     
   
HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLFC0000000 - 0xc4000000   (  64 MB).  Total pages: 16256er: -
console [ttyAM0
PowerPrep start initialize power...xc0000000   (  16 MB)nel command li
Battery Voltage = 1.42VAM0,115200
      .init
No battery or bad battery                                       detected!!!.Disaxfde00
      .text : 0xc0026000 - 0xc033d000   (3164 kB)entries: 256 (order: -2,
bling battery                                   voltage measurements./r/nLLCMayh table entries: 8192 (order: 3, 32768 bytes
Hierarchical RCU implementation.or
11 201215:26:EMI_CTRL 0x1C08404init_ddr_mt46v32m1etection of statocol fa           
             

Security
CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177he hash table entries: 512a
    vmalloc : 0xc4800000 - 0xf000
CPU: VIVT data cache, VIVT instruction cache-bl-1: fast normal d
    lowmem  :
regulator
Machine: iMX233-OLinuXino low cost boardable
NET: Registered protocol family 16m
Memory policy: ECC disabled, Data cache writeback 800 <--> 1575 mV at 1550 mV fast normalmal
     
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256 1575 mV fast normal     .text : 0xc0026000 - 0xc033d000   (3164 kB
     
    vmalloc : 0xc4800000 - 0xf0000000   ( 696 MB) normalieh-office) (g
Battery Voltage = 1.43Vnorm
    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)                                  detected!!!.Dis
    modules : 0xbf000000 - 0xc0000000   (  16 MB)750 mV fast normalnormalat
i.MX
bling battery   
      .init : 0xc0008000 - 0xc0026000   ( 120 kB)s./r/nLLCMay at 3300 mV fast normalLLLLLLLLLLLLLL
      .text : 0xc0026000 - 0xc033d000   (3164 kB)15:26:EMI_CTRL 0x1C08404init_ddr_mt46v32m10Frac 0
      .data : 0xc0356000 - 0xc0381a00   ( 175 kB)ast normalo low cost boa
LLLLLLLFCLJUncompressing
Hierarchical RCU implementation.l.C disabled, Data cache wri
reg
        RCU-based detection of stalled CPUs is disabled.uXinoR4 (hehopmajieh@hehopmajieh-office) (gcc versiontal
        Verbose stalled-CPUs detection is disabled.measurements./r/nLLCMay
 4.7.1 20120421 (prerelea
NR_IRQS:224#11 PREEMPT
Console: colour dummy device 80x30: power-test-1: fast normalit_ddr_
console [ttyAM0] enabled   
         
         
Bu
regulator: core version 0.5r, mobility grouping on.  T
NET: Registered protocol family 16), cr=0005317726192kernel.       
regulator: vddd: 800 <--> 1575 mV at 1550 mV fast normalole=ttyAM0,115200 root=/dev/mmcblk0p2 rw rootwrements./r
regulator: vdddbo: 800 <--> 1575 mV fast normalcost boardinux versi
 
ait ssp1=mmc0xff
11 2012
regulator: vdda: 1500 <--> 2275 mV at 1750 mV fast normal     
Battery
    DMA     : 0xfde00000 - 0xf
Dentry cach
regulator: vddio: 2800 <--> 3575 mV at 3300 mV fast normale kernel. : 0xc4800000 - 0xf0000000   ( 696 MB)     
Inode
regulator: overall_current: fast                               
      .
regulator: power-test-1: fast normal 0xfde00000 - 0xffe00000   (  32 MB)
regulator: cpufreq-1: fast normalU implementatio
    vmalloc : 0xc
i.MX IRAM pool: 28 KB@0xc4808000d detection of stalled CPUs is d
HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLFCrbose stalled-CPUs detecti
Built 1 zonel
    modules : 0xbf000000 - 0xc000
PowerPrep start initialize power...ff100
Console: colour dummy d
     
Battery Voltage = 1.41Vc0026000   ( 120 kB)d l
No battery or bad battery                                       detected!!xc033d000   (3164 kB) : 0xfde00000 - 0xffe                           

 
regulator: vdda: 1500 <--> 2275 mV at 1
Kernel command line: noinitrd console=ttyAM0,115200 root=/dev/mmcblk0p2 rw rootwator: vddio: 2800 <--> 3575 mV at 3300 mV fast normalR_IRQS:224   

      .data
ait ssp1=mmc- 0xc0381a00
PID hash table entries: 256 (order: -2, 1024 bytes)ol: 28 KB
Hierarchical RCU implem
regulator: mxs-du
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)r: mxs-bl-1: fast normalxc033d000
regulator: vdddbo: 800
regu
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)l
regulator: mmc_ssp-1: fast normal27
Battery Voltage =
NR_I
Memory: 64MB = 64MB totalp-2: fast normalevice 80x
Memory: 57208k/57208k available, 8328k reserved, 0K highmemdt normal is disabled.

Calib
regulator: power-test-1: fa
Virtual kernel memory layout:               
             
Calibrating delay loop... 226.91 BogoMIPS (lpj=1134592) root=/dev/mmcblk0
CPU: ARM926EJ-S [41069265] revision
pid_max: default: 32768 minimum: 301       
No bat
regulator: cpufreq-1:
Security Framework initializedche, VIVT instruction cacheol:
Mount-cache hash table entries: 512     
Machine: iMX233-OLinuXino low
CPU: Testing write buffer coherency: okLLLLLLLLLLL
Memory policy: ECC disabled
regulator: core version 0.5cache hash table ent
PowerP
NET: Registered protocol family 16in Zone order, mobility grouping o
regulator: vddd: 800 <--> 1575 mV at 1550 mV fast normalbad battery                           
Kernel command l
regulator: vdddbo: 800 <--> 1575 mV fast normalcblk0p2 rw rootwMachine: iM
Virtual kernel
   
regulator: mmc_ssp-2: fast normal 0xffff0000 - 0xffff1000   (   4
regulator: charger-1: fast normale entries:
     
    fixmap  :
regulator: power-test-1: fast normal5] revision 5 (ARMv5TEJ), cr=0005317
regulator: cpufreq-1: fast normal00 - 0xffe00000   (  32 MB)7
CPU:
i.MX IRAM pool: 28 KB@0xc4808000n cacherar
    vmalloc : 0xc4800
HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLt boardtion of sta     
                         
       
LLLLLLLFCLJUncompressing Linux...HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLL core vers
Inode-cache
        Verbose stalled-CPUs detection is disabled.y 160
LLLLLLLLLLLLLLLLLLLLLLLLLFC     
regulator: v
NR_IRQS:
PowerPrep start initialize power... device 80x30emory: 57208k/57208k a
Battery Voltage = 2.06VyAM0] enabledo: 800 <--
No battery or bad battery                                    1134592y layout:                             
             
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256         detected!!!.
con
regulator: mmc_ssp-2: fast normalregulator:
Cal
Kernel command line: noinitrd console=ttyAM0,115200 root=/dev/mmcblk0p2 rw rootwolta
regulator: power-test-1: fast normallt: 32768 minimum: 301: mxs-bl-1: fa
re
ait ssp1=mmcreq-1: fast
PID hash table entries: 256 (order: -2, 1024 bytes)ol: 28 KB@0xc4808000 table entries: 512 mmc_ssp-1:
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)LLLLLLLLLLLLFCting the kernel.dda: 1500
regulator: core vers
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)..ily 16pmajieh@hehopmajieh-office) (
Battery Voltage = 1.42
Memory: 64MB = 64MB totalo battery or bad battery
Memory: 57208k/57208k available, 8328k reserved, 0K highmembo: 800 <--> 1575 mV fast normal2012LLLLLLLLLLLLLLLLLLLLLLL
Virtual kernel memory layout:                             
    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)hehopmajieh@hehopmajieh-office) (gcc versionrac 0
    modules : 0xbf000000 - 0xc0000000   (  16 MB)mal command line: noinitr
 4.7.1 20120421 (prerel
      .init : 0xc0008000 - 0xc0026000   ( 120 kB) 2012regulator: charger-1: fast normal<-->

Linu
      .text : 0xc0026000 - 0xc033d000   (3164 kB) [41069265] revision 5 (ARMv5TE
Calibrating delay loop... 226.91 BogoMIPS (lpj=1134592)
pid_max: default: 32768 minimum: 301
Security Framework initialized
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
regulator: core version 0.5
NET: Registered protocol family 16
regulator: vddd: 800 <--> 1575 mV at 1550 mV fast normal
regulator: vdddbo: 800 <--> 1575 mV fast normal
regulator: vdda: 1500 <--> 2275 mV at 1750 mV fast normal
regulator: vddio: 2800 <--> 3575 mV at 3300 mV fast normal
regulator: overall_current: fast normal
regulator: mxs-duart-1: fast normal
regulator: mxs-bl-1: fast normal
regulator: mxs-i2c-1: fast normal
regulator: mmc_ssp-1: fast normal
regulator: mmc_ssp-2: fast normal
regulator: charger-1: fast normal
regulator: power-test-1: fast normal
regulator: cpufreq-1: fast normal
i.MX IRAM pool: 28 KB@0xc4808000
HTLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLLFC
PowerPrep start initialize power...
Battery Voltage = 1.42V

Need help, Please!
Thanks.

Kean

  • Jr. Member
  • **
  • Posts: 91
  • Karma: +3/-0
Re: Olinuxino micro doesn´t boot
« Reply #1 on: November 19, 2012, 12:38:03 PM »
Check if your board contains R17, and if so remove it.  This might be the cause of your problem.

For more info see https://www.olimex.com/forum/index.php?topic=59.0

Kean

ecolomato

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Olinuxino micro doesn´t boot
« Reply #2 on: November 19, 2012, 08:31:24 PM »
Thank you very much for your reply Kean.
My board doesn´t have R17. The place where it may be soldered is empty.
I have also tried all solutions for problems like mine in the forum:
Tried diferent sd-cards
Tried diferent filesystems from diferent links
Tried making sd-cards as root (without sudo)

The result is always the same (never booting).

Dataedge

  • Newbie
  • *
  • Posts: 23
  • Karma: +5/-0
Re: Olinuxino micro doesn´t boot
« Reply #3 on: December 06, 2012, 11:27:35 AM »
Hi all !

I've a similar problem ecolomato has, my Olinuxino-MAXI never booted.
I tried 2 different ways to create the SD yesterday (December 5 2012) :

http://olimex.wordpress.com/2012/09/06/imx233-olinuxino-get-started-making-the-arch-linux-sd-card/
and
http://archlinuxarm.org/platforms/armv5/olinuxino (recently updated I guess)

The boot sequence always hangs before login prompt, below last lines of boot log from:
https://docs.google.com/open?id=0B-bAEPML8fwlLXlxblQxWTVvZVU + https://docs.google.com/open?id=0B-bAEPML8fwlNDFUYkx0ZkNWV3c

Code: [Select]
WARNING : No battery connected !
Aborting power driver initialization
mxs-battery: probe of mxs-battery.0 failed with error 1
mxs watchdog: initialized, heartbeat 19 sec
mxs-mmc: MXS SSP Controller MMC Interface driver
ssp_set_rate: error -110
mxs-mmc mxs-mmc.0: mmc0: MXS SSP MMC DMAIRQ 14 ERRIRQ 15
dcp dcp.0: DCP crypto enabled.!
mxs-adc-audio mxs-adc-audio.0: MXS ADC/DAC Audio Codec
No device for DAI mxs adc/dac
No device for DAI mxs adc/dac
asoc: mxs adc/dac <-> mxs adc/dac mapping ok
ALSA device list:
  #0: MXS EVK (mxs adc/dac)
TCP cubic registered
NET: Registered protocol family 10
IPv6 over IPv4 tunneling driver
NET: Registered protocol family 17
registered taskstats version 1
mxs-rtc mxs-rtc.0: setting system clock to 1970-01-01 00:03:27 UTC (207)
RAMDISK: Couldn't find valid RAM disk image starting at 0.
Waiting for root device /dev/mmcblk0p2...
mmc0: new high speed SD card at address 1234
mmcblk0: mmc0:1234 SA02G 1.83 GiB
 mmcblk0: p1 p2 p3
usb 1-1: new high speed USB device using fsl-ehci and address 2
usb 1-1: New USB device found, idVendor=0424, idProduct=9512
usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 3 ports detected
usb 1-1.1: new high speed USB device using fsl-ehci and address 3
usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
smsc95xx v1.0.4
smsc95xx 1-1.1:1.0: usb0: register 'smsc95xx' at usb-fsl-ehci-1.1, smsc95xx USB 2.0 Ethernet, c2:dc:b1:e6:54:43

After some minutes it log endlessy:
Code: [Select]
INFO: task swapper:1 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
swapper       D c02c9a50     0     1      0 0x00000000
[<c02c9a50>] (schedule+0x320/0x3c0) from [<c02c9b70>] (io_schedule+0x80/0xe0)
[<c02c9b70>] (io_schedule+0x80/0xe0) from [<c00cf830>] (sync_buffer+0x44/0x4c)
[<c00cf830>] (sync_buffer+0x44/0x4c) from [<c02ca4a0>] (__wait_on_bit+0x54/0xa0)
[<c02ca4a0>] (__wait_on_bit+0x54/0xa0) from [<c02ca564>] (out_of_line_wait_on_bit+0x78/0x84)
[<c02ca564>] (out_of_line_wait_on_bit+0x78/0x84) from [<c012f048>] (journal_get_superblock+0x54/0x160)
[<c012f048>] (journal_get_superblock+0x54/0x160) from [<c012fb00>] (jbd2_journal_load+0x10/0x31c)
[<c012fb00>] (jbd2_journal_load+0x10/0x31c) from [<c011499c>] (ext4_fill_super+0x1758/0x20f0)
[<c011499c>] (ext4_fill_super+0x1758/0x20f0) from [<c00aecf0>] (get_sb_bdev+0x110/0x16c)
[<c00aecf0>] (get_sb_bdev+0x110/0x16c) from [<c010fc48>] (ext4_get_sb+0x18/0x20)
[<c010fc48>] (ext4_get_sb+0x18/0x20) from [<c00ae658>] (vfs_kern_mount+0x98/0x198)
[<c00ae658>] (vfs_kern_mount+0x98/0x198) from [<c00ae79c>] (do_kern_mount+0x34/0xe4)
[<c00ae79c>] (do_kern_mount+0x34/0xe4) from [<c00c5624>] (do_mount+0x6fc/0x7a0)
[<c00c5624>] (do_mount+0x6fc/0x7a0) from [<c00c5920>] (sys_mount+0x84/0xc4)
[<c00c5920>] (sys_mount+0x84/0xc4) from [<c0008e5c>] (mount_block_root+0xe8/0x284)
[<c0008e5c>] (mount_block_root+0xe8/0x284) from [<c00092b8>] (prepare_namespace+0x160/0x1c0)
[<c00092b8>] (prepare_namespace+0x160/0x1c0) from [<c0008c2c>] (kernel_init+0x154/0x198)
[<c0008c2c>] (kernel_init+0x154/0x198) from [<c00297ec>] (kernel_thread_exit+0x0/0x8)
INFO: task mmcqd:36 blocked for more than 120 seconds.
"echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
mmcqd         D c02c9a50     0    36      2 0x00000000
[<c02c9a50>] (schedule+0x320/0x3c0) from [<c02ca238>] (schedule_timeout+0x18/0x1d8)
[<c02ca238>] (schedule_timeout+0x18/0x1d8) from [<c02c9d94>] (wait_for_common+0xd4/0x1c4)
[<c02c9d94>] (wait_for_common+0xd4/0x1c4) from [<c0202e84>] (mxs_mmc_start_cmd+0x58c/0x954)
[<c0202e84>] (mxs_mmc_start_cmd+0x58c/0x954) from [<c020327c>] (mxs_mmc_request+0x30/0x68)
[<c020327c>] (mxs_mmc_request+0x30/0x68) from [<c01fa290>] (mmc_wait_for_req+0xfc/0x110)
[<c01fa290>] (mmc_wait_for_req+0xfc/0x110) from [<c0201114>] (mmc_blk_issue_rq+0x1b8/0x758)
[<c0201114>] (mmc_blk_issue_rq+0x1b8/0x758) from [<c0201b28>] (mmc_queue_thread+0xe8/0x110)
[<c0201b28>] (mmc_queue_thread+0xe8/0x110) from [<c0058d6c>] (kthread+0x78/0x84)
[<c0058d6c>] (kthread+0x78/0x84) from [<c00297ec>] (kernel_thread_exit+0x0/0x8)

The LAN connector LEDs are on, and sometimes the GREEN one blink (it is connected to a ethernet switch in a working network), but the system is always stuck as reported above. The image downloaded from archlinuxarm.org (single img file) hangs sooner, it doesn't reach the 'smsc95xx' initialization at all !

R14 is not mounted in my board, and I removed R17 , but without success...

What I'm doing wrong ?

olimex

  • Administrator
  • Hero Member
  • *****
  • Posts: 806
  • Karma: +22/-3
Re: Olinuxino micro doesn´t boot
« Reply #4 on: December 06, 2012, 01:04:36 PM »
MAXI never had problem with resistors so you shouldn't remove anything

is this card ours or you build it yourself?
if the card is ours check these:

1. measure your power supply it it provide enough power
2. check if you put the card completely to the end position
3. check your card with card reader



Dataedge

  • Newbie
  • *
  • Posts: 23
  • Karma: +5/-0
Re: Olinuxino micro doesn´t boot
« Reply #5 on: December 06, 2012, 02:18:39 PM »
Thank you for your reply,

I bought iMX233-Olinuxino-MAXI from Mouser Electronics days ago.

1) My power source is +12V 6A (Power Source WRDJ24FWX-U)
2) The SD card is positioned all inside the push-push socket
3) Checked the card (2GB Verbatim SD) with Windows and Linux with apparently no problems (also checked with fdisk "p" the card partitions following "making the ARCH Linux SD card" article instructions)

All suggestions are welcome.

 

Dataedge

  • Newbie
  • *
  • Posts: 23
  • Karma: +5/-0
Re: Olinuxino micro doesn´t boot
« Reply #6 on: December 06, 2012, 05:26:10 PM »
I was able to get my problem resolved.
Changed the SD (same capacity) from Verbatim (not working) to SanDisk and the system works perfectly !

Thanks for your support!