Is everyone enjoying their Agon's

Started by, July 27, 2023, 03:43:42 PM

Previous topic - Next topic

BBC Basic and CPM what's not to love.
software is starting to make it way
across as more people get hold of


I'm enjoying, but I'll really enjoy it when there is some additional programming documentation.


I finally got my AgonLight2 up and running.

I've never used BBC BASIC, so I am trying to learn.

I tried loading a ".bbc" file but it reset the device.

I'll have to try it out some more.


It seems that I have bricked my Agon Light 2 after using the Windows ESP programing tool for the VDP. Even after closing the UART and PROG jumpers and runing the Arduino sketch for 1.04 (video.ino) - it compiles fine but nothing is displayed when moving the jumpers open again. I did have mos v2.1.0 and vdp 1.04 (trying to upgrade to 2.1.0) like the console 8. Do I need to order another Agon Light 2 (shipping is high to the USA) or can this be solved?


It is hard to brick the board, probably you are perplexed or overwhelmed with info.

There is no MOS v2.1.0? Latest MOS is 1.0.4.

Refer to the recovery instructions at the end of this document:
Technical support and documentation manager at Olimex


I was able to un-brick my Agon Light 2 by surprisingly NOT closing the 2 jumpers (UART, PROG) and runing the Arduino IDE for the video.ino sketch which I saw it write this time. The MOS is at Console8 v2.1.0 but I would like to update the VDP from 1.04 to 2.1.0. I found the firmware.bin for 2.1.0 but when I run the *flash vdp firmware.bin   it says the something about the firmware.bin is not ESP32.   How can I correct this. I tried using the Windows ESP tool for programming the 0x1000 Bootloader.bin, 0x8000 Partitions.bin and the 0x10000 firmware.bin but when I have all 3 of them checked it says there is a COM3 16 bin overlap error - which I believe is from the Partitions.bin from what I can read into.  How can this be fixed OR what do I need to do to get the VDP updated to Console8 2.1.0 ?


I have no idea what is Console8 2.1.0 we recommend and load Quark VDP 1.04. Maybe try posting the same issue in the Facebook group of Agonlight project, probably more knowledgable people would have an idea what is going on. The Facebook group is here:
Technical support and documentation manager at Olimex


I just started using my Agonlight2 and I am not loving it. It is not able to read any SD card. I have gone over it with knowledgeable people in the Agon facebook group and they can't help me so I just put in a support ticket. Please advise how I can get this replaced. Thanks.


Refer to page 7 of this document on how to prepare the card:

If the issue remains drop an e-mail at make sure to include all details on what you have done and what is the result, maybe we can spot a problem.
Technical support and documentation manager at Olimex


I have successfully updated my Agon Light 2 VDP from 1.04RC3 to 1.04 by following the instructions from and then using the mos/flash.bin utility to update VDP to v2.8.0 and MOS to v2.2.3.

But using the same steps I can not update my Agon Origins' VDP from v1.04RC1 to v1.04.
Arduino IDE generates error message says the COM port is not connected so it can't upload the newly compiled VDP v1.04 to Agon Origins.  I used the Windows 11 device manager checked the COM port setting and found Agon Light 2 is automatically configure as COM port 3 when its USB cable is connected to my Windows PC but the Agon Origins is not configured to any COM port at all.  It just shows the Agon Origins is listed in the "other device" category on the Windows device manager listing.

Are the ESP32 of Agon Light 2 and Agon Origins the same or they are different?


Hi LubOlimex,

Following your information of CP2104 driver installation, I have successfully updated my Agon Origins' VDP to v2.8.0 and MOS to v2.2.3.  The procedures are the same as the above Agon Light2 update steps.  Thanks for the help.


This seems like driver issue. Agon Origins uses different and more popular USB chip - CP2104 - it requires different driver (AgonLight2 uses CH340T). Drivers can be downloaded from the official silabs web-site here:

Download and install the Windows driver and new COM should appear, the rest of the procedure should be the same.

Technical support and documentation manager at Olimex