Neo6502 - hdmi problem, doesn't work

Started by olivierBautista, October 31, 2023, 04:26:02 PM

Previous topic - Next topic


I can't get the Neo6502 to work, :o
I can put the .uf2 file in the rasberry 2040 with the usb-A cable and my laptop, this is ok. ;D

I connect an hdmi screen, a usb keyboard and a 5v power supply to the usb C.

I connect :
For Oric emulator
pin 10 of UEXT connector (GPIO 25) to pin 24 of 6502 bus connector (IRQ) using external wire.

To use F12 as RESET button (both Apple ][ and Oric)
I connect pin 9 of UEXT connector (GPIO 26) to pin 40 of 6502 bus connector (RESET).

To use F11 as NMI button (Oric)
I connect pin 8 of UEXT connector (GPIO 27) to pin 26 of 6502 bus connector (NMI).

And the Neo3502 makes a little noise when I type on the keyboard, but nothing more. :'(

I've tried several power supplies (5v 3000 ma)

I also tried changing the positions of switch 1.....
I can't find much documentation on Internet.

What else can I do? Do you have any ideas?

thank you in advance for your answers.

Best Regards, Olivier Bautista


So what exactly doesn't work? Did you try with other uf2 files from our ftp here:

Is your monitor with native HDMI? Is a TV or monitor?
Technical support and documentation manager at Olimex


I don't have an image, 8)
I did take my files from this ftp repository. ;D
It's on a tv or on a vga monitor with an hdmi adapter, :-\
I'll try with a pure HDMI monitor. :D


We've received some reports of some HDMI-VGA adapters causing issues, try with native HDMI an report back.
Technical support and documentation manager at Olimex