STMP1-SOM does not boot (without LiPo connected)

Started by BBit, June 04, 2023, 10:08:19 PM

Previous topic - Next topic



last week I just got a STMP1-SOM and STMP1(A13)-SOM-EVB. So I put both together and tried to start it up. Unfortunately there was not trace out seen on my terminal. After checking the UART-Bridge and the terminal SW it came to the point to check if all voltages are available.   

I found out that 2.86V seems to be a bit low at 3.3V1 (measurement point). A quick look into schematics and it had (or could have) something to do with the LiPo (or at least it has a relationship to it). After connect a LiPo the board comes up and I was happy, so far (even with a few kernel warnings from snd_... modules).

Now the issue is that the LiPo does not get loaded (even the LED CHGLED1 was off all the time) and as soon as the LiPo get's discharged the board does not boot again.

Is there any hint or advise to solve this issue? In addition it was not planned to used a LiPo anyhow, so it would be nice, if I can use the board even without one.



1. Which Linux image did you use? Is it the image from archive "STM32MP1-OLinuXino-SOM-bullseye-minimal-20220928-143706.img.7z"?

2. Did you prepare the card with balenaEtcher? Did you let it check what was downloaded to the card?

3. Did you check if you connected the USB-UART cable properly? It is common to connect RX and TX in reverse, or mirror the whole connection? Try all scenarios here.

4. Did you power the setup from the 5V DC jack?
Technical support and documentation manager at Olimex


First, thanks for reply.

  • yes (I tried both, SOM and SOM-BASE)
  • yes (It was successfully verified by BalenaEtcher)
  • yes (I got trace out after connect a LiPo to to the board. But after LiPo discharge the Board does not boot)
  • yes (an external power supply 5V/2A)

I also check boot selection switches (compared to boot modes mentioned in schematics) and tried another (new) SD Card. But as I mentioned, the boards starts from SD CARD once (with LiPo).


Looks like something burned. Why and how hard to determine based on the information we got so far. Can you measure all test points and give us the results, maybe we can figure it out. Notice that in case something burned you might need either to replace components or return the board for inspection. Take a look at our warranty and returns policy here:
Technical support and documentation manager at Olimex


Okay, thanks. I also thought this way. Really bad, but I'll need to return the board for inspection.