Audio is not supported on A10 Olimex with fresh Image (A10-OLinuXino-bullseye)

Started by Abhishek Zanjare, October 18, 2022, 03:52:44 PM

Previous topic - Next topic

Abhishek Zanjare

I was working on A10(bullseye) but Unable to enable Audio or Run any mp3, wave file.
I uploaded a Fresh Current Image of 2022 still no audio played.

Here The Output Of Command:

root@a10-olinuxino:/home/olimex# cat /proc/asound/cards
--- no soundcards ---

root@a10-olinuxino:/home/olimex# aplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib confmisc.c:767:(parse_card) cannot find card '0'
ALSA lib conf.c:4745:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4745:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory

I request olimex firmware to upload new image for Olimex Board with audio enable or some solution to it




A10-OLinuXino-LIME comes without audio jack so naturally the audio support is not enabled.
Technical support and documentation manager at Olimex

Abhishek Zanjare

Hello LubOlimex,

I Downloaded the Old image from:

And Audio is working good.

root@a10Lime:/home/olimex# cat /proc/asound/cards
 0 [sunxicodec     ]: sunxi-CODEC - sunxi-CODEC
                      sunxi-CODEC  Audio Codec
 1 [sunxisndhdmi   ]: sunxi-sndhdmi - sunxi-sndhdmi

root@a10Lime:/home/olimex# aplay /usr/share/sounds/alsa/Front_Center.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

But As I upload bullseye Latest Image the Audio Doesn't work.
what is the problem?


> what is the problem?

There is no problem just A10-OLinuXino-LIME has no audio output hardware by default (jack and all). So we haven't enabled such support in the Olimage Linux image. It was a decision we made because it is better to have these pins available if somebody needs them, instead configure them for hardware that is not there.

You need to edit the dts to enable the audio and also rebuild the u-boot.

What to change? In here:


&codec {
 status = "okay";

Maybe put it between these two:

&ehci0 {
 status = "okay";

&ehci1 {

It is the same situation with A20-OLinuXino-LIME2 but we have expansion shield that adds audio jack and we have overlay configuration for that shield to enable the audio. Maybe take a look at the overlay for the shield and compare. Notice that the shield is not compatible with the A10 board!
Technical support and documentation manager at Olimex

Abhishek Zanjare

>You need to edit the dts to enable the audio and also rebuild the u-boot.

*There no such files sun4i-a10-olinuxino-lime.dts in board

root@a10-olinuxino:~# find / -name sun4i-a10-olinuxino-lime.dts
find: '/sys/module/smsc/drivers': Input/output error

I am using this:

root@a10-olinuxino:~# cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION="11 (bullseye)"

*So Later I forcefully download sun4i-a10-olinuxino-lime.dts from your git link and try to Uboot following this link :-

but Cant able to Install any toolchain Setup

root@a10-olinuxino:~# apt-get install gcc-4.7-arm-linux-gnueabihf ncurses-dev uboot-mkimage build-esse
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'libncurses-dev' instead of 'ncurses-dev'
Package uboot-mkimage is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  u-boot-tools-olinuxino u-boot-tools

E: Unable to locate package gcc-4.7-arm-linux-gnueabihf
E: Couldn't find any package by glob 'gcc-4.7-arm-linux-gnueabihf'
E: Couldn't find any package by regex 'gcc-4.7-arm-linux-gnueabihf'
E: Package 'uboot-mkimage' has no installation candidate
E: Unable to locate package build-esse

*Can you please give proper dts file name & location of it and How to Uboot this thing?


The wordpress link you used as basis is from 2013. This was 9 years ago. It is no longer the way to build the images.

Olimage is build using the instructions at the bottom of this document:
Technical support and documentation manager at Olimex


 Looking to put the voice on A10 board (Bullseye version).
 I followed all the steps as mentioned above. Modified the DTS, compiled everything, modified the Uboot also as mentioned in the pdf. We could get the sound card listed as device. However when I try to play the voice, it gives an error as follows.
" pcm_write:2058: write error: Input/output error".  Couldn't figure out, what I am missing.
can anyone throw some light?

Error in verbose:

root@KKB3333:/usr/local/config# aplay 1.wav -vv
Playing WAVE '1.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Plug PCM: Hardware PCM card 0 'sun4i-codec' device 0 subdevice 0
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 44100
  exact rate   : 44100 (44100/1)
  msbits       : 16
  buffer_size  : 22052
  period_size  : 5513
  period_time  : 125011
  tstamp_mode  : NONE
  tstamp_type  : MONOTONIC
  period_step  : 1
  avail_min    : 5513
  period_event : 0
  start_threshold  : 22052
  stop_threshold   : 22052
  silence_threshold: 0
  silence_size : 0
  boundary     : 1445199872
  appl_ptr     : 0
  hw_ptr       : 0
################################+                  | 63%aplay: pcm_write:2058: write error: Input/output error



Did you double and triple check the settings in alsa mixer, seems like this audio might be disabled, use the "M" button to mute unmute channels, make sure that you increase the volume of channels above 0.

I can get the same error if I mute one of the channels and then attempt to use it.
Technical support and documentation manager at Olimex


Thanks a lot.
It works.
will test more and update if there is any issue.