July 16, 2024, 04:21:26 PM

Quectel BC66 Arduino Project

Started by belveder79, January 13, 2021, 10:53:45 PM

Previous topic - Next topic


Hi, I have a question concerning the NB-IoT module BC66. I tried compiling some of the github examples but failed:

.platformio/packages/framework-quectel/arduino/cores/bc66/interface.h:27:10: fatal error: os_wizio.h: No such file or directory

I followed the install instructions on GitHub, but was not able get it done. Any ideas? Thx....


Try to reinstall Quectel platform:

PIO Home > Platforms ... find Quectel and press Uninstall button.

Then install:

PIO Home > Platforms > Advanced Installation

paste https://github.com/Wiz-IO/platform-quectel

PIO Home > Boards ... select Olimex-NB-IoT-DevKit



I followed he documentation on


saying one should use


which I did, and that did not compile with the fatal error. I also exchanged the platform-quectel with the wizio version - no luck.

The third combination is


but that does not work either with the BC66 examples. For get_info e.g. I get

src/main.cpp:20:42: error: 'class LDEV' has no member named 'getVersion'; did you mean 'version'?
   Serial.printf("Arduino      %s\n", Dev.getVersion());


Hi, im trying to set up plaformio with the NB-IoT dev kit according to the instructions. but am stuck with the error once I start to install the quectel on plaformio. it says "could not find one of 'package.jason' manifest files in the package. Any idea?


Make sure that using these instructions exactly:


I think something was left over and you need to manually delete partially downloaded files and start from the beginning.

Here are some suggestions from forums on how this can be fixed:



Technical support and documentation manager at Olimex



Thank you for the reply. I tried all these options before reaching the support forum. also tried 2 different environments (mac, Windows) still the problem same it cannot find the package.json file. i just noticed there is no such file(package.json) in the gituhub repo as well. is it normal?

and even though the platform installation failed with this error, I can see that quectel platform gets installed on platformio. however, I cannot compile examples in plaformio due to the same error as the jason file is missing.

much appreciate some advice


I have some bad news. It appears that the PlatformIO option for Quectel chips might be gone. It appears the lone developer has frozen any work and support on it in the last few months.

> something I noticed while looking at github repository, the file which says missing "package.json" is not in the repo as well. is it normal?

Yes, it is normal, manifest.json is taken remotely. If you open platform.json (in Windows it is in C:\Users\YOUR_USERNAME\.platformio\platforms\quectel) you'd see that manifest.json is taken from

  "packageRepositories": [

It seems that both locations are unavailable. Bintray seems to have shut down. PlatformIO on the other hand no longer hosts files that easily (they started analyzing what they host after people started abusing this service). I have opened an issue for the developer but he seems to have cut ties with Quectel, you can see the issue I opened here:


I believe the whole platform for quectel does not fit the new scheme for PlatformIO so it needs editing which the developer is not willing to do or support for free. My advice is to ignore the project. Maybe try the Arduno project for AT commands:


If that is still no go maybe use the software tools recommended by Quectel for their BC66 modules.

I will fix our documentation to no longer recommend this repo.
Technical support and documentation manager at Olimex



Thanks again for your prompt reply and actions. so I'm stuck with hardware that I purchase from you that no longer can be used. we were hoping to use this Olimex BC 66 module for commercial purposes and seems it hits a wall now. any plan to provide further support? since your still manufacturing and selling the BC66 modules?


> Thanks again for your prompt reply and actions. so I'm stuck with hardware that I purchase from you that no longer can be used.

It can be used just not with that specific piece of software (PlatformIO extension for Quectel chips). It can still be used with any software tools released by Quectel that support BC66 or any BC66 software tools. Like Arduino for Quectel here: https://github.com/Wiz-IO/Arduino-Quectel-BC66

> any plan to provide further support?

We provide full hardware support for our boards.

If you ask me whether we plan to write own PlatformIO plugin that works with BC66 - then no, we don't plan such support. We lack knowledge and resources for this.

> since your still manufacturing and selling the BC66 modules?

We are not software developers hence we provide any software and our experience with any software for free. There is no guarantee that the software we have used when we designed the board would still work. We try our best when possible to make it work, but in extreme cases like this when the whole project gets dropped there isn't much we can do.

This happens sometimes - chip manufactures drop software support but we still manufacture our boards as long as possible and as long as there is interest. Why? Because some people already developed own software or don't need updates and only need the hardware.

For example, we have this product ARM-JTAG-COOCOX that was compatible with an open source environment, which worked well for awhile but suddenly the developers completely abandoned the CooCox project, deleted the web-site, everything. But still some people use the last known version so we have the debugger for sale.
Technical support and documentation manager at Olimex