MPIDE or Arduino IDE with Chipkit extension

Started by KeesZagers, April 11, 2022, 04:35:23 PM

Previous topic - Next topic


Olimex has the reference to MPIDE for an Arduino compatible environment for the PIC32 boards, like Duinomite Mega. However in the mean time the Chipkit extensions are supported by the Arduino consortium as an extension for the PIC32 boards. Chipkit offers also support for the Olimex products in the extension. I believe the old MPIDE has become obsolete. I installed the Chipkit extension in my Arduino IDE and the program I had running in the MPIDE environment compiled without any problem. Also the download to the Duinomite with the old bootloader ran without any errors. However after that the board was not recognised anymore by the PC. The bootloader was still functioning and after the download of the code with the old MPIDE the system was up and running again. Does anyone have the same experiences?


This is strange, it is rare to brick the bootloader via USB programming. But for ChipKit I guess you should try their bootloader, I am not sure if the original bootloader can work with Arduino, it was made like 8 years ago.

Did you try using the ChipKit bootlaoder? The bootloader might work differently. Did you try to enter bootloader mode with the button pressed + reset?

Technical support and documentation manager at Olimex


The bootloader is not bricked. Only my application probably disabled the USB communication. I have tried now only "The hello world" application and the old MPIDE code showed the message on Serial (default serial port) on the USB terminal, however compiled on the Arduino IDE with Chipkit extension nothing is showed on the USB terminal. As far as I can see in the board defaults the Serial1 and Serial2 are connected to 2 local serial ports, but I don't know what they did with the default Serial.
A simple blinking LED is working without any problem.
As far as I can see they did not change the bootloader code. Bootloader start with reset also works without any problem.


Problem solved.

Skipped the:
(seems not to be implemented by Chipkit)

First send something to the USB serial port and after that "The hello world" is displayed on the USB terminal.