LoRa868 unresponsive on multiple Arduino boards and different code

Started by conor, November 21, 2021, 02:23:17 pm

Previous topic - Next topic

conor

I have two LoRa868 modules, neither of which I can get working with Arduino Uno, or ESP32 using Arduino code.

I eventually went for the simplest example code (dump registers) from the recommended LoRa library but still had no success.

I'm using completely standard wiring as follows on the Arduino.

3V3 <> 3V3
GND <> GND
NSS <> D10
DIO0 <> D2
RESET <> D9
MISO <> D12
MOSI <> D11
SCK <> D13

Both the simple Library and RadioHead had the same result - It's always "init failed"

When I switched to a generic RFM95 module from China, it worked immediately.

Is there extra wiring or pins states required for the LoRa868 compared to those Chinese modules?

Thanks

LubOlimex

Technical support and documentation manager at Olimex


conor

Any further thoughts on this? I tried again over Christmas with the two modules I bought from you. Both failed to respond. Wiring checked and re-checked. Replaced with generic RFM95 and things worked perfectly. Any suggestions for what I can try next to get them working?