remote debugging using gdb/gdbserver

Started by walid, July 06, 2014, 07:28:29 PM

Previous topic - Next topic



I'm trying to debug a simple arm-hello program with gdb/gdbserver(7.7.1) cross compiled for arm-linux-gnueabi using serial/USB link

I'm using olimex A13 target with Linux a13-armel 3.4.67+

I ran gdbserver on the target :

#gdbserver /dev/ttyS0 arm-hello
Process arm-hello created; pid = 10696
Remote debugging using /dev/ttyS0

So I ran the host gdb and tried to establish the connection between host and target, but couldn't establish the connections channel :

# arm-linux-gnueabi-gdb arm-hello
(gdb) set serial baud 115200
(gdb) set debug remote 1
(gdb) set debug serial 1
(gdb) target remote /dev/ttyUSB0
Remote debugging using /dev/ttyUSB0
sending packet: $qSupported:multiprocess+;qRelocInsn+#2a...putpkt: Junk: debugging using /dev/ttyS0
readchar: Input/output error
Remote side has terminated connection. GDBserver will reopen the connection.

Please help !
Thank you.


You can also debug directly on the board. gcc and gdb are not so large.