Keyboard combination Super+Right does not work

Started by khumarahn, January 29, 2024, 02:08:59 AM

Previous topic - Next topic



I managed to get Teres-1 up and running with a modern kernel and u-boot. (With a lot of help from Kreygen!) The new software is way better than it was last time I worked with Teres.

I'm hitting an annoying old problem now: the key combination Super+Right does nothing (as can be seen in `showkey -a`). While Super+Left works correctly, as well as Super, Left and Right separately.

I tried building and flashing the most recent firmware in
but that did not change anything.

Is this a bug or a feature? I mean, is it a hardware or software problem? Is there anyone for whom it works correctly?


I don't seem to have this issue on my teres and i suspect that being a gentoo-related issue so proposing to first focus on making teres work on gentoo smoothly and reliably and then investigate the cause optionally try the armbian image to see if you can reproduce it there.
* Community Lead Developer of TeresDevelopment
* Downstream Maintainer of Linux and BSD* compatibility for OLIMEX Teres-I
* World record holder in annoying Tsvetan with questions about OLIMEX Teres-I hacking