ESP32-GATEWAY-EA - Flashing fails - strange signal levels ESP_EN GPIO0

Started by makimu, February 06, 2021, 08:58:31 pm

Previous topic - Next topic


I recently got my ESP32-GATEWAY-EA (Rev. G) plus housing and tried to flash demo code to the device.

The only connection (excluding the osci probes) is a USB cable to the computer where I execute "ESD-IDF: Flash (UART) your project" on the ESP32_Gateway_Ethernet_v4.0 Example from your github repo in Visual Studio Code with ESP-IDF plugin. 

Unfortunately flashing always fails.
"Failed to connect to Espressif device: Timed out waiting for packet header"

So I connected an osilloscope to monitor the two relevant signals during the flashing attempt: ESP_EN (via Extension:Pin3) and GPIO0 (via D4:Pin2). The result is attached.

The good news: The CH340T seems to work. There are signals visible.

First question: How would this sequence look like correctly?

I don't know what this would look like correctly, but these signals look odd to me. ESP_EN is not limited to 3.3 V although directly connected to the ESP-Module. GPIO0 does not reach clear 0V.

Do you have any ideas or hints what is going wrong here?


I would suggest testing with all USBs, then with another computer and another USB cable. Pretty sure it is related to UBS timings.

Re-install CH340T drivers (despite seeing it recognized).

This is very popular error message. It depends on a lot of factors but usually related to USB timings. Search for "ch340 Failed to connect to Espressif device: Timed out waiting for packet header".

Sometimes I regret we went for the auto-reset sequence on the board and didn't just solder a reset button. Yes, that would have made it harder for customers to program (by requiring two-button sequence every time the board has to be programmed) but would have made it more consistent.
Technical support and documentation manager at Olimex


I ignored the board now for half a year and gave it another try today.

Now it works. I don't know what makes the difference, but it works. As far as I remember I did the same things a few months ago.  ???

Hardware is still the same, but I reinstalled all software. In case it is helpful to someone, I carefully recommend the following versions:

cat /etc/debian_version

uname -a
Linux buerodev 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux

python --version
Python 3.7.3

Visual Studio Code
Version: 1.57.0
Commit: b4c1bd0a9b03c749ea011b06c6d2676c8091a70c
Date: 2021-06-09T17:18:42.895Z
Electron: 12.0.9
Chrome: 89.0.4389.128
Node.js: 14.16.0
OS: Linux x64 4.19.0-14-amd64

python -m pip --version
pip 21.1.2 from /usr/local/lib/python3.7/dist-packages/pip (python 3.7)




Thanks for the update. Probably the drivers and the USB timings in the software improved.
Technical support and documentation manager at Olimex