Ethernet Interface Not Showing Up

Started by afancher, November 09, 2020, 05:37:21 am

Previous topic - Next topic

gennariello

Hi,

I had the same issue, but I can't edit the u-boot options because I'm working on a headless device. Is there any other way to solve the problem?

I also notice that I can't connect through ssh using the account in the user manual:
user:root
pass:olimex

my board is A64-OLinuXino-1Ge16GW  and I've tried both buster than focal OS image

Can you help me?
Thank you,
Gennariello

LubOlimex

You can't log as user root over SSH...

Try user olimex with password olimex.
Technical support and documentation manager at Olimex

JohnS

You can always then
su -
(or sudo bash etc)
to get to root.

John

gennariello

Ok,

thank you
=====
So, in order to save time to other user...a quick recap

users are:
   root: olimex        (without ssl login)
   olimex: olinuxino  (with ssh login and sudo privileges)
 
To fix the ethernet not working issue after the first reboot:
   1) during the first boot, run "sudo olinuxino-display" (from O.S. cli, NOT from u-boot cli)
   2) choose the option "disable" and reboot the board
===

LubOlimex

Thank you for the summary but are you sure about this one:

Quoteolimex: olinuxino  (with ssh login and sudo privileges)

I think it should be olimex with passowrd olimex
Technical support and documentation manager at Olimex

gennariello

December 16, 2020, 09:49:43 pm #20 Last Edit: December 16, 2020, 09:51:16 pm by gennariello
Quote from: LubOlimex on December 15, 2020, 01:29:18 pmThank you for the summary but are you sure about this one:

Quoteolimex: olinuxino  (with ssh login and sudo privileges)

I think it should be olimex with passowrd olimex
Sorry, you are right...I've mixed the two topics 😌

coapvid

he lshw output confirmed the status and node name associated with the hardware.

spiceagent11

Mostly yes, but things like closed drivers need to be included. If you look at the likes of Samsung, they tell you to repo the Google repository and then dump their files into this, overwriting where required.

aquohn

I'm getting the same issue with my A64-OLinuXino-1Ge16GW-EA board on the latest kernel version, but disabling the auto-detection worked for me too. The olinuxino-display script is in /usr/sbin, by the way - took me a while to find it.

LubOlimex

Yes, by default the Linux loads settings for display and display is multiplexed with Ethernet. To use the Ethernet:

1) Make sure the PTH jumper PHYRST1 is open
2) Disable any LCD via olinuxino-display
Technical support and documentation manager at Olimex