Wake from suspend (power button)

Started by robertojones, September 13, 2020, 03:21:27 pm

Previous topic - Next topic

robertojones

Hi,

First of all I would like to say how happy I am with this board so far and with Olimex in general.

I came from using a Pine64 with its own LCD, but gave up after I realised I was basically stuck with kernel 3.10 if I wanted to use the LCD - Not good enough for my project (and honestly, not good enough in 2020)!

I am really impressed by the level of support provided for the A64-OlinuXino, both the up-to-date OS images and sources and the fact that getting the LCD working just involves activating an overlay.

I just have one issue at the moment - Using the current Ubuntu Focal image I am unable to wake the board from suspend mode. I have tested with rtcwake and it is definitely able to wake from suspend (so not getting stuck), it just does not seem to be recognising the power button as a wakeup source. Linux is picking up the button and pops up the little 'Log out' window when it is pressed. The latest Armbian image (from Armbian site) seems to be pick this up OK but for a number of reasons I would rather use the Olimex-provided Ubuntu.

In both OSes the default option seems to be suspend-to-idle, this is fine for my purposes. I'd love to get a deeper suspend working but I understand this may be quite difficult (if possible at all) so I will tackle this later on, separately.

Can anyone help me find the setting to enable wake from the power button, or what I can do next to try and find it? I have decompiled the DTBs from Olimex-Ubuntu and Armbian and compared them and not found anything, but I am honestly a bit out of my depth (though I am happy to experiment and teach myself new Linux stuff).

Thanks!

LubOlimex

It would be interesting to see if the behavior is same with the Bionic Base release, we are still gathering feedback from the Focal images - there are quite a few reports of problems, so the wake up behavior might also be a degradation related to Focal. Does the wake up work better with Bionic Base images?
Technical support and documentation manager at Olimex

robertojones

September 14, 2020, 12:03:20 pm #2 Last Edit: September 14, 2020, 12:50:04 pm by robertojones
Thank you for responding so quickly.

I've just tried with the Bionic Base image, I get the same behavior - The power button is recognised and brings up the menu, the system is able to suspend / resume with rtcwake, but it does not wake from suspend when the power button is pressed.

I've also tried the Buster image just in case - Same behavior again.