September 26, 2021, 12:43:48 am


Started by rousea, September 09, 2020, 07:27:26 pm

Previous topic - Next topic


I use Eclipse and OpenOCD to debug projects, and I have two ARM-UB_OCD inferfaces and one ARM-USB-OCD-H.  I used to be able to work well with this combination, and use the serial port on the interfaces.  However, when Eclipse and OpenOCD were updated I had to change the drivers to libusbK.  The combination still works, but I can't use the serial ports.

I would now like to restore the serial ports, so I tried updating the drivers to those downloaded in CDM v2.12.04 OLIMEX or cdm20808.  Different combinations of interface and drive resulted in different listings in Device Manager.  Some combinations included a COM port (one combination configured both drivers as COM ports!).  However, none of them worked with the debugger.

Am I stuck with having to use libusbK drivers and no serial port?


You probably installed the LibUSBK drivers both interfaces of each ARM-USB-OCD units. In order to have both program interface and serial interface you would probably need to have one set of drivers for the program interface (most likely the LibUSBK ones that you used so far) and for the serial interface FTDI drivers. You can try these FTDI drivers for the serial port interface:
Technical support and documentation manager at Olimex