serial port on UEXT connector

Started by mciocco, May 14, 2020, 05:37:46 am

Previous topic - Next topic

mciocco

I need to use this serial port with the latest Olinuxino image, which is the tty? I have to set or declare  something in the OS?
Thank You in advance

Faruk

Debug serial port is setting to ttyS0 be default. All image should working on this way(If you didn't any different settings). This port is uart0.

UEXT connector has uart3. If you want take output on UEXT connector, you should enable uart3. You will can check how to enable uart3 on that you have OS image and you should use ttyS3 for uart3.

If you have armbian image, you can enable uart3 with use armbian-config settings. 

LubOlimex

In Olimage images try:

olinuxino-overlay

This script allows enabling different ports and buses - use arrow keys to move up, down, left or right, "space" to enable or disable different interface, once done - press "tab" to move selector down to "ok" and "cancel" options, press "enter" over "ok" or "cancel", if you've made changes restart the board with "reboot now" so that the changes get applied. There is another script:

olinuxino-display

It is used to set different video output options.
Technical support and documentation manager at Olimex

mciocco

I've tried to look at olinuxino-overlay but, whixh is the switch to enable uart3, i can't recognize it
there are LCD, spidev, SPI1, TWI0,1, but nothing that sound as uart or serial or tty.

tHANK You in advance

Marcello

Faruk

If you use this image: https://www.armbian.com/olimex-lime-a64/, use "sudo armbian-config" command in terminal and go on "system settings". You will see uart settings in here. You should enable uart3 in here and rebot your system.

mciocco

awful I am using the last Olimage, but now I will set a n amrbian image too.

Faruk

Actually, I don't think so difficult for Olimage too. Just the process different