No ethernet interface available

Started by sidney, February 07, 2020, 04:48:01 am

Previous topic - Next topic

sidney

Hello,

I used the official image for the A10-lime, 'a10_Lime_debian_3.4.90_release_3.img'. This image boot well but one thing is not working : i have no ethernet interface available (ifconfig return 'lo' only). What is the procedure to activate it, please?

Also, is buildroot is well supported for this board?

Thanks!

sidney

It seems to me that the A10-olimex-lime board have been clearly abandoned / not maintained anymore :
- https://olimex.wordpress.com/2014/06/23/a10-olinuxino-lime-debian-build-with-kernel-3-4-90/ point to no more available google drive ressources
- the building instructions found at ftp://staging.olimex.com/Lub-clients/A10_build/5-debian_3.4.90_release_4/ points to an unavailable http://www.emdebian.org/
- the only image the work the most is found at ftp://staging.olimex.com/Lub-clients/a10_Lime_debian_3.4.90_release_3.img.7z. Still, no ethernet interface and a way too old kernel, not suitable for a fresh new project.
- all torrent links are just dead

As far as i tested, only buildroot with mainline kernel -could- help : no onboard nand and still no ethernet interface, even while playing with the device tree (dts overlay taken from armbian github repo).

My guess is the hardware will be available forever BUT the software pieces are already burned long time ago.

Am i just discouraged or am i right?
Thanks for your reply.

LubOlimex

February 12, 2020, 08:51:56 am #2 Last Edit: February 12, 2020, 08:57:57 am by LubOlimex
A10 should be supported in mainline kernel, it is too similar to A20 to not be supported. We haven't published a mainline image tho, so you might want to look for some unofficial source and build more recent kernel image yourself.

There is A10-OLinuXino-Lime_defconfig. Maybe check here:

https://www.digikey.com/eewiki/display/linuxonarm/A10-OLinuXino-LIME

If the torrents are not working you can find the images at the ftp address here:

ftp://staging.olimex.com/Allwinner_Images/A10-OLinuXino-LIME/Debian/sd/
Technical support and documentation manager at Olimex

sidney

Thanks for your reply.

In fact, i manage to make this work with pains.
I have created a script to adapt piCore to this board and possibly many other boards.
Sadly, it is not possible to post a zip file in the thread so i have posted a link to my dropbox : https://www.dropbox.com/s/hgtzx3a35fgw1df/build_custion_piCore.zip?dl=0

For the community, it would be useful to pin this thread or to update this one https://www.olimex.com/forum/index.php?topic=2285.0

Thanks!