ESP32-EVB with LAN8710a might be incompatible with the ESP32 API 4.0

Started by ESP32_l, November 28, 2019, 07:52:45 pm

Previous topic - Next topic

ESP32_l

Hello everyone,
i've the following problem. I'm using the (ESP32-EVB) with the current esp-idf (API 4.0). This API changed the ethernet structure completely. This is also stated under the following link https://www.esp32.com/viewtopic.php?t=11305. That's why the olimex examples are maybe not compatible with the current IDF. On the other side the new IDF provides some simple examples but only support the LAN8720 and some other transceivers but not LAN8710a, which is used in the ESP32-EVB. Are there any simple solutions or even new implementations from olimex to get the ESP32-EVB ethernet running while using the new IDF?
Thanks for your efforts.

olimex

easy workaround is to not use 4.0 until migrate guide from 3.x to 4.0 is released by Espressif so we can update our examples