A20 universal linux image

Started by roderick, March 12, 2019, 06:50:28 pm

Previous topic - Next topic

roderick

Hello,
I've just tried to boot the theoretically universal Armbian_5.72.1_Olinuxino-a20_Debian_stretch_next_4.19.17 image (taken from ftp://staging.olimex.com/Allwinner_Images/A20-OLinuXino/1.latest_mainline_images/stretch/images/) on my A20-SOM device, but with no success.

The following output is displayed:

**File not found /boot/dtb/ **
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
** File not found /boot/dtb/overlay/sun7i-a20-fixup.scr **
...
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
SCRIPT FAILED: continuing...
Card did not respond to voltage select!
...
Device 0: unknown device
ethernet@01c50000 Waiting for PHY auto negotiation to complete...... TIMEOUT !
Could not initialize PHY ethernet@01c50000


I'd really appreciate any help with this, because I really need to make this work!!

Thanks in advance

Rodrigo

LubOlimex

Probably the EEPROM doesn't contain data about the board and the universal image won't automatically recognzie your board. Interrupt u-boot with space and manually configure the image for your board. In u-boot type "olinuxino" for help and refer to chapter "Manual board configuration" of the wiki here: https://www.olimex.com/wiki/ArmbianHowTo#Manual_board_configuration
Technical support and documentation manager at Olimex

roderick

March 14, 2019, 12:22:19 pm #2 Last Edit: March 14, 2019, 12:48:03 pm by roderick
Hello,
first of all, thanks to your quick response.
Secondly, I've tried to manually configure the image for my A20-SOM board, but unsuccessfully. If I write
=> olinuxino config write 7664 d
Erasing EEPROM configuration...
ERROR: Failed to init eeprom!
Erasing MMC configuration...
Writting EEPROM configuration...
ERROR: Failed to init eeprom!
Writting MMC configuration...
=> olinuxino config info
Failed to read the EEPROM configuration!
=> saveenv
=> reset

After reboot, the system starts properly.
Thanks :-)

olimex

my guess is you have old board which has no EEPROM on it

LubOlimex

Good, glad to help.

Your hardware revision of A20-SOM has no EEPROM at all. The EEPROM of A20-SOM was added in hardware revision E. However, this scenario was considered and it this case the board identification information gets written to the SD card instead.
Technical support and documentation manager at Olimex

saarijoki

July 10, 2019, 06:44:05 pm #5 Last Edit: July 10, 2019, 06:54:41 pm by saarijoki
Sorry to hijack a thread, but how exactly do I halt the u-boot since my keyboard isn't recognized during the boot (an older A20 Micro)?

I've tried two USB keyboards now...

To clarify:
- I'm powering the board from the power jack with 12V 2A power supply.
- The keyboards work just fine with my PC
- The keyboards work just fine with 3.4 Jessie
- Also, the Micro works just fine with the 3.4 Jessie distro

LubOlimex

Interrupting the kernel boot and staying in u-boot is kind of a pain. You need to keep press the space key repeatedly even before seeing the countdown. If the keyboard doesn't get initialized before the prompt, you might need to use other method of accessing the board. For example, try a USB-serial converter between the board's debug port and a PC running serial terminal software then using the PC keyboard to interrupt the prompt.
Technical support and documentation manager at Olimex

mauricio

Hello all

Sorry also for hijacking this thread but think is good place to claim that there is an error at this https://www.olimex.com/wiki/ArmbianHowTo armbian how to

Point 5, Manual Board Configuration
it says
Quote from: undefinedSet configuration, for example if you have A20-OLinuXino-LIME2-e16Gs16M, hardware revision K you would have to type:
olinuxino config 9604 kShould say
olinuxino config write 9604 k
Please note "WRITE"

If not by the pertinent post of @roderick, I'ld be now bald pulling my last hair

Thanks @roderick

LubOlimex

Thanks, this is now fixed, please let me know if you spot other issues in the wiki article - I'd try to fix them ASAP.
Technical support and documentation manager at Olimex