How to Power LCD Touchscreens?

Started by HarrisonCreates, November 12, 2019, 03:24:42 am

Previous topic - Next topic

HarrisonCreates

Hello All,

I am attempting to get my Olimex A-64-1Ge4GW to power and display on an LCD cable. To present, I have done the following:

1.) Stopped u-boot and manually configured the board to search for LCDs.
2.) I ran saveenv, and reset
3.) When I plug in the board, the LCD panel flashes white for a second but nothing else displays. The board boots perfectly fine when connected to HDMI.
4.) I am running the board on WiFi, so there's shouldn't be any Ethernet/LCD mumbo jumbo going on.

I even tried powering the touchscreen with a separate 5V barrel jack while the A64 was on and still nothing. Any tips?

Thank you!!

LubOlimex

Did you close the jumper PHYRST1?

What is the display exactly?

Can you shows us a picture of the connection between the board and the LCD? Maybe upload it to another web-site and give us the link.
Technical support and documentation manager at Olimex

HarrisonCreates

November 12, 2019, 08:01:24 pm #2 Last Edit: November 12, 2019, 08:47:24 pm by HarrisonCreates
I soldered PYSRST1 shut and it seems to work now, I was trying to use the little plastic piece the board came with as a bridge but realized it wasn't making contact with the pins. I am doing light prototyping, so a solder bridge works just fine!

I am now having a different issue. The board begins to boot but somethings gives out and the board shuts down. From reading what other people have posted, this is due to a bad power supply. I am using a Samsung Fast Charger block, which from what I read is capable of producing around 2A at 5V. Is this not enough to power the board and touchscreen?

One additional mention; I plan to run this system on a 3.7V Lithium battery; the one I have is rated for 3000mAH, so would this product enough current to run both the board and screen?

LubOlimex

Where do you apply the power from the charger? To the micro USB connector or to the barrel power jack?

The Li-Po is alright it would keep the setup operational for quite some time.
Technical support and documentation manager at Olimex

HarrisonCreates

Hello LubOlimex,

It's a relief to hear about the battery! Thank you for letting me know, I'll find a battery with the correct wire polarity!

Regarding the charger, I am connecting it to the barrel jack. I soldered my own USB cable to the barrel jack wires, so maybe the wire gauge is getting in the way of delivering optimal current. Either way, maybe I should try with the battery, since the board is optimized to convert 3.7V to 5V and pull enough current.