Welcome, Guest

Author Topic: Random shutdown of Olimex Lime 2 emmc rev.K.  (Read 119 times)

tejas.s

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Random shutdown of Olimex Lime 2 emmc rev.K.
« on: September 11, 2019, 01:28:04 PM »
I am using Olimex Lime 2 Emmc Rev.k with Armbian_Ubuntu_bionic_5.1.12 for a project. The Board shuts down randomly. Its not a powersupply issue as I have tried with different stable power supplies.

Its not a freeze or a sudden power down of the board.  The board undergoes a complete shut down procedure.

 
I checked the log entries in /var/log/syslog log file. There is a entry of board going to shut down but I couldn't find the reason for shut down.

Is there a way to find out if the board got shut down because of the Power-button press, shutdown command from a SSH client, shutdown because of temperature or shutdown because of under voltage ? Is there a log file i can check to find the reason for shutdown?

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1968
  • Karma: +50/-3
Re: Random shutdown of Olimex Lime 2 emmc rev.K.
« Reply #1 on: September 11, 2019, 03:03:00 PM »
Do you use the power jack to power the board? Or do you use the mini USB connector?

>  The board undergoes a complete shut down procedure.

As if you ran "shutdown now" command? Strange.

How often does it happen?
Technical support and documentation manager at Olimex

tejas.s

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: Random shutdown of Olimex Lime 2 emmc rev.K.
« Reply #2 on: September 11, 2019, 03:14:01 PM »
Hi LubOlimex,

> Do you use the power jack to power the board? Or do you use the mini USB connector?

  I use the Power Jack, 5V power supply. Tried different power-banks and powersupply adapters.

> As if you ran "shutdown now" command?
  Yes, I have verified it with checking the UART0 debug port. It goes through the shutdown procedure.

> How often does it happen?
It's very random. So, I wanted to know if I can check a log file for the shutdown entry and conclude if it's a faulty board or some other reason.

tejas.s

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
Re: Random shutdown of Olimex Lime 2 emmc rev.K.
« Reply #3 on: September 13, 2019, 10:25:32 AM »
Hi LubOlimex,

I found the reason for shut-down, its because of xfce power manager.

Hardware setup :: Olimex Lime 2 Rev.k + 7" LCD + 5V power supply through the power jack. No battery is connected to the lime 2 board.


when the board boots up, the xfce power manager shows that the Battery is connected and it's in charging mode. The current charge value of the battery changes randomly like 92%, 56% and etc. When it reaches 0% the board will shut down. It completes the shut down procedure.

The following is the terminal output, to find the battery status. Even though the battery is not connected you can observe that it returns the Voltage and reports that the battery is present.

Code: [Select]
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/voltage_now
2865000
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/present
1
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/online
1
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/capacity
0
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/capacity
0
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/online
1
root@olinuxino:~# cat /sys/class/power_supply/axp20x-battery/voltage_now
2879000
root@olinuxino:~# [  OK  ] Stopped Unattended Upgrades Shutdown.
[  OK  ] Stopped target Timers.
[  OK  ] Stopped target Sound Card.
.....
.....
.....

The board shut down as soon as the capacity reached 0%.

I have three Lime 2 Rev.K boards, the behaviour is seen in all.

What could be the reason for this behavior?
Should I disable xfce power manager?


Note : I am using the Armbian_Ubuntu_bionic_5.1.12 OS with Lime 2 rev.K.



LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1968
  • Karma: +50/-3
Re: Random shutdown of Olimex Lime 2 emmc rev.K.
« Reply #4 on: September 13, 2019, 01:46:15 PM »
> I am using the Armbian_Ubuntu_bionic_5.1.12 OS with Lime 2 rev.K.

I believe it might be a corrupted image or failed apt upgrade. Can you try with the newest image that we recommend, it is available for download from here:

ftp://staging.olimex.com/Allwinner_Images/A20-OLinuXino/1.latest_mainline_images/bionic/images/
« Last Edit: September 13, 2019, 01:48:51 PM by LubOlimex »
Technical support and documentation manager at Olimex