A13 OLinuXino MICRO device tree with Mali GPU

Started by rob2020, June 03, 2019, 12:04:53 pm

Previous topic - Next topic

rob2020

Hi,

I'm trying to get the Mali GPU working with a mainline Linux version. I can't seem to find a device tree containing the Mali 400 GPU for this board (A13 OLinuXino MICRO)? Can anybody help me out? Shouldn't it be in the sun5i.dtsi file soc section?

thank you.

-Robert

olimex

this board has only 256MB of RAM, if I remember correctly Mali alone requires between 128 and 256MB to run, so you will able to use it with board at least with 512MB RAM

rob2020

I would like to give it a try as a board with more memory would be a cost factor. What would I have to add to the device tree?

thanks.

-Robert

WimRoose

I think I managed to assemble a working dt with mali GPU enabled. Finally :-)

mali: gpu@1c40000 {
                        compatible = "allwinner,sun4i-a10-mali", "arm,mali-400";
                        reg = <0x1c40000 0x10000>;
                        interrupts = <0x45 0x46 0x47 0x48 0x49>;
                        interrupt-names = "gp", "gpmmu", "pp0", "ppmmu0", "pmu";
                        clocks = <0x2 0x31 0x2 0x62>;
                        clock-names = "bus", "core";
                        resets = <0x2 0x9>;
                        assigned-clocks = <0x2 0x62>;
                        assigned-clock-rates = <0x16e36000>;
                        phandle = <0x81>;
                };

This works on A13-WiFi

Welshman

Quote from: WimRoose on March 13, 2020, 02:50:05 pmI think I managed to assemble a working dt with mali GPU enabled. Finally :-)

mali: gpu@1c40000 {
                        compatible = "allwinner,sun4i-a10-mali", "arm,mali-400";
                        reg = <0x1c40000 0x10000>;
                        interrupts = <0x45 0x46 0x47 0x48 0x49>;
                        interrupt-names = "gp", "gpmmu", "pp0", "ppmmu0", "pmu";
                        clocks = <0x2 0x31 0x2 0x62>;
                        clock-names = "bus", "core";
                        resets = <0x2 0x9>;
                        assigned-clocks = <0x2 0x62>;
                        assigned-clock-rates = <0x16e36000>;
                        phandle = <0x81>;
                };

This works on A13-WiFi


Can you provide the full dts file ?

or where this extra code is placed ,  thanks