Welcome, Guest

Author Topic: A13-SOM-256 failures?  (Read 608 times)

rasteri

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
A13-SOM-256 failures?
« on: April 16, 2019, 05:58:24 PM »
I've designed an open source project based on your excellent A13-SOM-256 boards. The project is here if you're interested - https://github.com/rasteri/SC1000 .

However one of my users is having problems - his A13-SOM-256 boards refuse to boot (hanging at "Starting Kernel..."), or boot but then kernel panic.

I have tried both my custom buildroot linux distribution and the Debian image available on the Olimex website - they both do the same thing.

The broken boards have "E2173CA 1361" printed on the A13, and "H5TQ2G63BFR H9C 243A" printed on the SDRAM.

The working boards have "E2060CA 22K1" printed on the A13, and "H5TQ2G63DFR PBC 410V" printed on the SDRAM. I'm guessing these are a newer revision.

The non-working boards also look different from the boards I've been testing with. They have a slightly darker-red soldermask, no Olimex logo on the top side, and have different revisions of the A13 and SDRAM ICs.

I have attached pictures of the boards as well as boot logs -

Boot messages from buildroot : https://pastebin.com/CKeUjk3M
Boot messages from debian : https://pastebin.com/cM6QSAuD

Are these boards simply faulty, or is there something I have to change in U-Boot or the linux kernel itself to get them to boot on the slightly different IC revisions?




LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1951
  • Karma: +50/-3
Re: A13-SOM-256 failures?
« Reply #1 on: April 17, 2019, 03:21:20 PM »
As you correctly noticed the memories are different. Sometimes original components are unavailable for purchase and we have to purchase replacements that are supposed to behave the same but that might not be always the case. Unfortunately, this sometimes leads to the need of Linux changes. Both RAM and flash memories seem to be very dependent on specific u-boot versions and in certain cases further steps, configuration, or patching might be required.
 
Can you test if the boot problem persists with this new image for A13-SOM-256? It uses mainline u-boot and can be downloaded directly from this FTP location: ftp://staging.olimex.com/Allwinner_Images/A13-SOM/Debian/sd/A13_SOM_Debian_kernel_34_90_100kHz_I2C_WIFI_USB_LAN_X_touch_256MB_release_2.zip

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

rasteri

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: A13-SOM-256 failures?
« Reply #2 on: April 17, 2019, 08:24:13 PM »
Hi Lub, thanks for your reply.

Can you test if the boot problem persists with this new image for A13-SOM-256?

I have downloaded that image and it seems a lot more stable - I haven't seen a kernel panic or failed boot (so far).

However, I now need to incorporate this fix into my buildrooted OS. Hopefully changing U-Boot for a newer mainline version will help.

Is there any chance you can send me the U-Boot configuration you used to build the working image? I want to make sure all my RAM settings are the same as yours.

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1951
  • Karma: +50/-3
Re: A13-SOM-256 failures?
« Reply #3 on: April 22, 2019, 04:58:31 PM »
Hello,

You can see the update for build instructions here: https://github.com/OLIMEX/OLINUXINO/blob/master/SOFTWARE/A13/A13-SOM-build/A13_SOM_kernel_3.4.90_building_description_with_mainline_u-boot_2.txt

This GitHub folder: https://github.com/OLIMEX/OLINUXINO/tree/master/SOFTWARE/A13/A13-SOM-build contains the u-boot files already built, so you can skip to step 5 of the instructions to replace just the u-boot.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

rasteri

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: A13-SOM-256 failures?
« Reply #4 on: May 04, 2019, 12:25:24 AM »
Switching to uboot 2019.01 with the configuration file provided by Olimex seems to have fixed all the problems I was having. I'll need to do some more tests but I haven't seen a single kernel panic or failed boot so far.

Thanks very much for you help.

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1951
  • Karma: +50/-3
Re: A13-SOM-256 failures?
« Reply #5 on: May 08, 2019, 02:06:21 PM »
Thank you for the update. Glad the behavior improves with newer kernel.
Technical support and documentation manager at Olimex