Welcome, Guest

Author Topic: Updating MODRFID-1356MIFARE to version 2.1.8 must be downgraded to 1.03 first  (Read 181 times)

JMKeyreader

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
When we purchase new MODRFID-1356MIFARE boards from Olimex, they come with software version 2.0. But since this version has bugs, we have to upgrade it to version 2.1.8.
But updating directly to version 2.1.8 is not possible.
1.) First downgrade to version 1.03
2.) Then update to version 2.1.6
3.) Finally update to version 2.1.8
Then it works with sw version 2.1.8

This is a tideous procedure.
There are 2 possible solutions
1.) Can Olimex deliver the MODRFID-1356MIFARE with software version 2.1.8?
OR
2.) Deliver the MODRFID-1356MIFARE with atleast software version 2.1.6?
The wiki page does not have a link to version 2.1.8

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1882
  • Karma: +47/-2
Thank you for the feedback.

> But updating directly to version 2.1.8 is not possible.

I can confirm this problem, we were aware of it. But since new boards are delivered with latest firmware it shouldn't be an issue.

> Can Olimex deliver the MODRFID-1356MIFARE with software version 2.1.8?

After this post we tested few boards from the shop. They had 2.1.8 version. So this had been done.

>The wiki page does not have a link to version 2.1.8

This is now fixed. Thank you for the report.
Technical support and documentation manager at Olimex