Welcome, Guest

Author Topic: Boot Error "SPL: Unsupported Boot Device!"  (Read 624 times)

Faruk

  • Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Boot Error "SPL: Unsupported Boot Device!"
« on: February 20, 2019, 12:29:21 PM »
Hello

I endeavor kernel and boot events. So I try boot OLinuxino-A13 via spiflash(in FEL mode). I created 'u-boot-sunxi-with-spl.bin' file and wrote to on spiflash(I use sunxi-tools). When I boot my board with
Code: [Select]
./sunxi-fel uboot u-boot-sunxi-with-spl command it is work. But when I reset to board although I write the u-boot-sunxi-with-spl.bin in spiflash, board return
Code: [Select]
SPL: Unsupported Boot Device error.

Whole error message in below.
Code: [Select]
U-Boot SPL 2019.04-rc1-00141-g63f7e3fca3 (Feb 19 2019 - 17:23:48 +0300)␍␊
DRAM: 512 MiB␍␊
CPU: 1008000000Hz, AXI/AHB/APB: 3/2/2␍␊
SPL: Unsupported Boot Device!␍␊
SPL: failed to boot from all boot devices␍␊
### ERROR ### Please RESET the board ###

How can I fix this issue? Thanks.
« Last Edit: February 20, 2019, 01:10:06 PM by Faruk »

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1984
  • Karma: +50/-3
Re: Boot Error "SPL: Unsupported Boot Device!"
« Reply #1 on: February 20, 2019, 04:39:01 PM »
Are you trying to boot from SPI flash?
Technical support and documentation manager at Olimex

Faruk

  • Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Re: Boot Error "SPL: Unsupported Boot Device!"
« Reply #2 on: February 21, 2019, 06:55:08 AM »
Yes. Additionally after this step I'll also try to install a small system from the SPI flash. First I try boot from SPI flash.

Faruk

  • Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Re: Boot Error "SPL: Unsupported Boot Device!"
« Reply #3 on: February 21, 2019, 07:53:39 AM »
I exceed this step. I researched and I saw SPL_SPI_SUNXI is not enabled(Actually so simple config, should not have been overlooked). I enabled SPL_SPI_SUNXI. A13 board boot from spiflash now. Thanks. 

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1984
  • Karma: +50/-3
Re: Boot Error "SPL: Unsupported Boot Device!"
« Reply #4 on: February 21, 2019, 08:03:21 AM »
That is very interesting. I am looking at the schematic of A13-OLinuXino and A13-OLinuXino-WIFI and I can't find SPI flash memory, maybe I am understanding something wrong. Did you add own SPI flash?

Some of our A20 boards have SPI flash, these have *16M* suffix in their name, for example "A20-OLinuXino-MICRO-e4Gs16M" . The latest A20 images has script that allows booting from the SPI memory.
Technical support and documentation manager at Olimex

Faruk

  • Newbie
  • *
  • Posts: 30
  • Karma: +0/-0
Re: Boot Error "SPL: Unsupported Boot Device!"
« Reply #5 on: February 21, 2019, 08:26:35 AM »
Yes I added SPI flash. I prefered modification instead of buying new one. I think it is going fine :)