PIC-P67J60 demo. No Telnet connection.

Started by ffomich, June 15, 2018, 12:46:19 pm

Previous topic - Next topic

ffomich

Hi,
I try to connect via Telnet to the PIC-P67J60 board with pre-built PIC-P67J60.hex firmware. I use Putty, port 23. IP address is correct - I get it from COM port output & using Microchip Ethernet Discoverer.exe.
When I click "Open" button in Putty it closes.

Is Telnet enabled in the pre-built firmware?
If Yes, how to open Telnet connection with board?

LubOlimex

June 15, 2018, 02:15:14 pm #1 Last Edit: June 15, 2018, 03:02:14 pm by LubOlimex
Copy-paste the IP address that you find with Ethernet Discoverer in your web-browser.

Edit: Looking at the source code of the official demo it also seems that the Telnet is enabled; maybe try to download the official demo to the board (if you haven't already); it is available here: https://www.olimex.com/Products/PIC/Proto/PIC-P67J60/resources/PIC-P67J60_demo.zip

In the code in file "TCPIP OLIMEX_P67J60.h" you can see:

"#define STACK_USE_TELNET_SERVER         // Telnet server"

Then search for Telnet Options

#define TELNET_USERNAME         "admin"
#define TELNET_PASSWORD         "microchip"
Technical support and documentation manager at Olimex

ffomich

Web-page loads successfully.

1. Telnet via Putty
Telnet
192.168.85.175, port 23
Open

Putty windows closes.

2. Telnet in Wndows7
cmd > telnet
Microsoft Telnet > open 192.168.85.175:23
Connecting to 192.168.85.175:23... Can't open this node, port 23.


3. Telnet in Wndows7
cmd > telnet
Microsoft Telnet > open 192.168.85.175

or
cmd > telnet 192.168.85.175

Microchip Telnet Server 1.1
(for this demo, type 'admin' for the login and 'microchip' for the password.)
Login: admin
Password:
Logged in successfully


Press 'q' to quit

SNTP Time:    1529071169
Analog:              950
Buttons:         1 1 1 1
LEDs:    1 1 1 1 1 1 0 1

LubOlimex

Strange. Maybe the TCP IP stack used as a basis for the example has some trouble with certain telnet clients.

BTW you have two times Windows 7 with same procedure. Maybe #3 is Windows 10?
Technical support and documentation manager at Olimex

ffomich

Telnet via Putty is from Windows7 too.

Here is dump when I try to open Telnet connection to IP_address
https://drive.google.com/file/d/1fvVyfTkRXR6NuRToqDsLW1uMWXk0_uqO/view?usp=sharing
Connection opens correctly.

Here is dump when I try to open Telnet connection to IP_address:port
https://drive.google.com/file/d/1nz1LSaKVPJjupeGX9WpZmfr7QYBOwR6b/view?usp=sharing
Connection refused.