ESP32-EVB crashes when connecting to MacPro

Started by mamuesp, April 13, 2018, 07:07:21 pm

Previous topic - Next topic

mamuesp

April 13, 2018, 07:07:21 pm Last Edit: April 13, 2018, 08:59:41 pm by mamuesp
First of all, I love the concept of the Olimex boards with the special UEXT capabilities to develop prototypes based on ESP32 that can be easily expanded. That's why I chose these boards as the basis for development because of their flexibility. I have already worked with NodeMCU on ESP8266 and ESP32 basis, and successfully used some ESP32 generic development boards as well as the large ESP-WORVER-KIT from Espressif. On the one hand with the Arduino IDE and also with PlatformIO. Now I would like to install mongoose OS on the ESP32-EVB on my Mac pro. So far, nothing special.

But then a big problem occurred - my MacPro throws a kernel panci exception when I connect the board to the USB port. I connected it directly, without an additional hub. Furthermore I tried to connect it with an additional, switched on external 5V/2A power supply attached to the board, because I suspected that the inrush current might be too high. But no matter what I try, there is always the kernel panic exception - no chance to install the board without rebooting the computer.

Is there any experience with this phenomenon or does anyone have any idea what I could do? Any help would be appreciated...

Edit: Jsut to be sure I eleminated other potential error sources ... changed the USB cable (used a really good one), used the board as the only USB device on my Mac Pro ... no change! But on my Windows machine, it will be accessible at first sight, but then, the flashing process fails with errors:


[Apr 13 19:58:35.852] Fetching https://github.com/mongoose-os-apps/demo-c/releases/download/2.0/demo-c-esp32.zip...
[Apr 13 19:58:38.737] Loaded demo-c/esp32 version 1.0 (20180403-161237/???)
[Apr 13 19:58:38.737] Opening COM7 @ 115200...
[Apr 13 19:58:38.752] Connecting to ESP32 ROM, attempt 1 of 10...
[Apr 13 19:58:40.719]   Connected, chip: ESP32D0WDQ6 R1
[Apr 13 19:58:40.719] Running flasher @ 460800...
Flashing error: failed to run flasher: failed to talk to flasher: flasher did not respond



LubOlimex

April 16, 2018, 10:00:06 am #1 Last Edit: April 16, 2018, 12:53:06 pm by LubOlimex
I suspect the problem is in the drivers for MAC. ESP32-EVB uses CH340 USB-serial converter. ESP-WORVER-KIT uses FTDI USB-serial converter. These different converters require different drivers.

Try installing these: https://www.olimex.com/Products/Breadboarding/BB-CH340T/resources/CH341SER_MAC.ZIP

About the Moongose - Mongoose OS uploader is known to work poorly with CH340T (the USB-serial converter in Olimex ESP32-EVB). So I'm mainly suspecting a problem with the uploader software (or the commands issued to the uploader). It can also be an issue between the uploader software and the driver associated with CH340T.

Can you test with lower baud rate? "Running flasher @ 460800" might be too high. Also test with bigger timout and maybe reconnect feature enabled. If you can access the command line interface try the following command (the important part is "--esp-baud-rate 0"):

mos flash --port <YOUR_PORT> --esp-baud-rate 0

Did you report the error (with the full log) to the mongoose team? It might be a well-known driver or programmer problem.

Can you test with another flashing tool - for example, ESP-IDF or esptool https://github.com/espressif/esptool ; or via Arduino IDE for ESP32 that also uses esptool: https://github.com/espressif/arduino-esp32 ?
Technical support and documentation manager at Olimex

mamuesp

Thank you for your hint, but as I had time issues for develpoing a prototype, I switched to another board and now I'm trying to connect it with MOD-IO via I2C. Works partly ...