Welcome, Guest

Author Topic: Problem with dtb file 'som-evb'  (Read 192 times)

toto255

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Problem with dtb file 'som-evb'
« on: May 20, 2018, 11:05:19 PM »
Hi,

I get an Olimex-SOM with the Olimex-SOM-EVB feature,

My problem is, when i modify the uEnv.txt the board doesn't restart.

I just followed this procedure: https://www.olimex.com/wiki/AM3352-SOM

Code: [Select]
- Open uEnv.txt for editing with:

root@AM335x:~# nano /uEnv.txt

- edit the first line to:

fdtfile=am335x-olimex-som-evb.dtb (or the dtb file you need)

- save the edit by pressing "CTR"+"X"; then pressing "Y"; finally hit "Enter"

- reboot the board with:

reboot

In the boot, I have only am335x-olimex-som.dtb and not am335x-olimex-som-evb.dtb for my board.

Where can I find am335x-olimex-som-evb.dtb?

Thanks.

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1709
  • Karma: +42/-2
Re: Problem with dtb file 'som-evb'
« Reply #1 on: May 21, 2018, 08:34:51 AM »
Which image do you use? I believe the description about the dtb replacement fits only the image with the newer kernel:

The recommended one (older kernel): https://www.olimex.com/wiki/images/c/c6/AM3352_debian_3_12_VGA_1024x768_preliminary_release_4.torrent

Or the not recommended one (newer kernel): https://www.olimex.com/wiki/images/9/94/AM335x_debian_4_4_VGA_800x600_release_5.torrent
Technical support and documentation manager at Olimex

toto255

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Problem with dtb file 'som-evb'
« Reply #2 on: May 22, 2018, 12:06:54 AM »
I use the Stable official releases (recommended)

but when i plug a keyboard, he dont work

that's why I thought that it was necessary to follow the procedure below

toto255

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Problem with dtb file 'som-evb'
« Reply #3 on: May 23, 2018, 06:11:12 PM »
Code: [Select]
[  284.471289] usb 2-1: reset high-speed USB device number 2 using musb-hdrc
[  284.911446] usb 2-1.1: new high-speed USB device number 7 using musb-hdrc
[  285.019530] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1006
[  285.026785] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  285.034469] usb 2-1.1: Product: Keyboard Hub
[  285.038946] usb 2-1.1: Manufacturer: Apple, Inc.
[  285.043802] usb 2-1.1: SerialNumber: 000000000000
[  285.055095] hub 2-1.1:1.0: USB hub found
[  285.059413] hub 2-1.1:1.0: 3 ports detected
[  285.088083] usb 2-1.1: USB disconnect, device number 7
[  285.491444] usb 2-1.1: new high-speed USB device number 8 using musb-hdrc
[  285.599502] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1006
[  285.606757] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  285.614441] usb 2-1.1: Product: Keyboard Hub
[  285.618918] usb 2-1.1: Manufacturer: Apple, Inc.
[  285.623771] usb 2-1.1: SerialNumber: 000000000000
[  285.638537] hub 2-1.1:1.0: USB hub found
[  285.644166] hub 2-1.1:1.0: 3 ports detected
[  285.741340] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.747420] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.755502] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.762965] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.769033] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.777030] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.784488] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.790556] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.798564] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.805957] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.813220] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.819292] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.827352] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.834629] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.840706] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.848773] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.856462] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  285.863799] usb 2-1.1: USB disconnect, device number 8
[  285.869343] hub 2-1.1:1.0: activate --> -19
[  286.111464] usb 2-1.1: new high-speed USB device number 9 using musb-hdrc
[  286.219523] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1006
[  286.226783] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  286.234466] usb 2-1.1: Product: Keyboard Hub
[  286.238945] usb 2-1.1: Manufacturer: Apple, Inc.
[  286.243797] usb 2-1.1: SerialNumber: 000000000000
[  286.259021] hub 2-1.1:1.0: USB hub found
[  286.264618] hub 2-1.1:1.0: 3 ports detected
[  286.361331] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  286.367411] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  286.375793] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  286.382901] usb 2-1.1: USB disconnect, device number 9
[  286.881445] usb 2-1.1: new high-speed USB device number 10 using musb-hdrc
[  286.989505] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1006
[  286.996765] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  287.004446] usb 2-1.1: Product: Keyboard Hub
[  287.008924] usb 2-1.1: Manufacturer: Apple, Inc.
[  287.013779] usb 2-1.1: SerialNumber: 000000000000
[  287.028479] hub 2-1.1:1.0: USB hub found
[  287.034105] hub 2-1.1:1.0: 3 ports detected
[  287.131316] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  287.137395] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  287.145747] hub 2-1.1:1.0: hub_port_status failed (err = -71)
[  287.153131] usb 2-1.1: USB disconnect, device number 10
[  287.481447] usb 2-1.1: new high-speed USB device number 11 using musb-hdrc
[  287.589521] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1006
[  287.596781] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  287.604462] usb 2-1.1: Product: Keyboard Hub
[  287.608940] usb 2-1.1: Manufacturer: Apple, Inc.
[  287.613794] usb 2-1.1: SerialNumber: 000000000000
[  287.628523] hub 2-1.1:1.0: USB hub found
[  287.634158] hub 2-1.1:1.0: 3 ports detected
[  287.658076] usb 2-1.1: USB disconnect, device number 11
ping google.com
ping: unknown host google.com

I have these errors when trying to connect a keyboard or an ethernet cable on LAN2
« Last Edit: May 23, 2018, 06:13:03 PM by toto255 »