Welcome, Guest

Author Topic: ESP32-EVB - Flasihing from Mini USB Adapter  (Read 435 times)

Ruppie

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
ESP32-EVB - Flasihing from Mini USB Adapter
« on: January 20, 2018, 05:31:35 AM »
Hello, i asöways got an error message when i try to flash the code to the board.

What are the correz settings if the pot is detected as COM 5 on my Windows 10 System.
Waht must the string for the Serual flash settings look like.?

Marc

Ruppie

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: ESP32-EVB - Flasihing from Mini USB Adapter
« Reply #1 on: January 20, 2018, 10:55:58 AM »
Hello;
Acccording to my System Device Manager, my COM Port is COM5.

I am using Windows10, and according to a hint ypo can check your port by connecting / disconnecting from USB
, while typing "ls /dev/tty*" into the Msys2 MinGW terminal:

I have noticed that my Settings for the serial flash tool port are: "/dev/tty  /dev/ttyS4"

In the end i got the following error message:

"serial.serialutil.SerialException: could not open port '/??/COM5': WindowsError(                                                                                                                                                                                               3, 'Das System kann den angegebenen Pfad nicht finden.') --> "System can't find the Path"


Any ideas why this happens and how to fix ?

Greatings Marc

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1713
  • Karma: +43/-2
Re: ESP32-EVB - Flasihing from Mini USB Adapter
« Reply #2 on: January 22, 2018, 11:10:57 AM »
This doesn't seem to be related to the hardware or the driver of ESP32-EVB.

Probably Msys2 MinGW installation or the settings are incorrect. It can also be relatated to lack of administration privileges when running CMD under Windows 10.

Try changing "/dev/tty /dev/ttyS4" to /COM5 as suggested here: https://github.com/espressif/esp-idf/issues/30

Maybe the port is busy, try changing the COM port number from Windows Device Manager.

Try running all software as administrator.
Technical support and documentation manager at Olimex

Ruppie

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: ESP32-EVB - Flasihing from Mini USB Adapter
« Reply #3 on: January 22, 2018, 07:48:57 PM »
@LubOlimex

Problem solved: Iguess the promlem was not to start "as administrator".

Thanks ;-)