Re: MSP430-JTAG-TINY-V2 Windows 10 "cannot connect to programmer"

Started by Priyanka Deshmukh, January 16, 2018, 03:23:34 PM

Previous topic - Next topic

Priyanka Deshmukh

I update mz windows 10 and the programmer was working fine.
Now after recent update, When we try to program MSP430F169 and select the required "txt file", it says no data loaded in data section. The program is loaded but no data.
If we continue it says, not able to connect the programmer.
Also the port says USB in jtag gui but the windows 10 device manager lists it as com port.
I understand this may be a problem with the windows 10 and tried reinstalling new drivers, changing the digital sinature to off for windows.. etc but it is of no use.

I followed the post.... Topic: MSP430-JTAG-TINY-V2 Windows 10 "cannot connect"  (Read 3217 times) and tried all steps but no use.


The "no data loaded in data section" is quite typical if your hex/txt/bin file has only program memory code, but no data memory code.

The entry for MSP430-JTAG-TINY-V2 in Windows 10's Device Manager should say "Olimex Tiny v2.00 JTAG for MSP430 (COM #)". If it says different then the problem is in the driver installation procedure. Try again steps 1. and 2. from the post you mentioned: - make sure to follow them blindly and do not skip disabling driver signature enforcement.
Technical support and documentation manager at Olimex