Welcome, Guest

Author Topic: ATSAME70 Xplain Kit, ATSAMS70 custom board with Olimex ARM-USB-TINY-H, OpenOCD  (Read 1377 times)

abhisheklolage

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Hi all,

I have ATMEL's ATSAME70 Xplaind Kit which runs with CMSIS-DAP interface correctly through OpenOCD.

I want to connect to the board using the JTAG adapter "Olimex ARM-USB-TINY-H". I use Ubuntu 16.04 and using the latest OpenOCD version 0.10 which supports SAMS, SAME, SAMV targets. FTDI library was installed and OpenOCD was configured for the same.

While using the above jtag adapter thorugh OpenOCD:

sudo openocd -f /usr/local/share/openocd/scripts/board/atmel_same70_xplained.cfg

I get the following output:

Open On-Chip Debugger 0.10.0+dev-00226-g1c2e3d4 (2017-12-29-01:35)
Licensed under GNU GPL v2
For bug reports, read
        http://openocd.org/doc/doxygen/bugs.html
Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.
adapter speed: 1800 kHz
cortex_m reset_config sysresetreq
Info : flash bank command
srst_only separate srst_gates_jtag srst_open_drain connect_deassert_srst
Info : clock speed 1800 kHz
Error: JTAG scan chain interrogation failed: all zeroes
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: atsame70q21.cpu: IR capture error; saw 0x00 not 0x01
Warn : Bypassing JTAG setup events due to errors
Error: Invalid ACK (0) in DAP response
Error: Invalid ACK (0) in DAP response



I also have a custom-made PCB which has a SAMS70Q20 ATMEL chip. The same problem - "scan chain interrogation failed; saw all zeros" error is seen with SAMS70 as well.
 
Need urgent help.

Thank you.

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1752
  • Karma: +45/-2
Technical support and documentation manager at Olimex