Welcome, Guest

Author Topic: USB camera UVC error  (Read 5149 times)

delphi

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
USB camera UVC error
« on: September 03, 2015, 07:39:36 PM »
USB camera UVC error
[   95.291174] uvcvideo: Failed to query (GET_DEF) UVC control 8 on unit 2: -1 (exp. 2).                                               
[   95.291212] uvcvideo: Failed to query (GET_DEF) UVC control 1 on unit 2: -1 (exp. 2).                                               
[   96.301067] uvcvideo: uvc_dequeue_buffer is failed!!(ret:-11)
We use the core from self-destroyer account. All actionse were accroding to Linaro build image instruction.
It seems that neither Olimex neither Radxa not tested the 3.036+ with standart UVC camera and it is not working.
We try to use 4 different web cameras and it seems that all of ones have the same error.
We have seen a couple of discussion with Radxa patches but it seems that some of them are at the current branch of Olimex and another ones have no effect.
We have a plan to bought 10-20 SOM modules every month. Olimex engineers should understand that this using this board and USB camera is very important part of many applications.

delphi

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: USB camera UVC error
« Reply #1 on: September 03, 2015, 08:40:56 PM »
Guvcview has no image and write
Error grabbing image
liv4l2: error dequeuing buffer: Invalid argument

delphi

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: USB camera UVC error
« Reply #2 on: September 03, 2015, 08:55:06 PM »
I don't know why but luvcview has an image from one of cameras (widecam 1050) but have a green picture from another one.
Chromium cann't use successfully no one cameras

MBR

  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +19/-0
Re: USB camera UVC error
« Reply #3 on: September 10, 2015, 06:47:47 PM »
What does the luvcview say when you capture the green image? For example, for my (working) UVC webcam, it's

Code: [Select]
Device information:
  Device path:  /dev/video0
Stream settings:
  Frame format: YUYV (MJPG is not supported by device)
  Frame size:   640x480
  Frame rate:   30 fps

I saw webcams that reported MJPEG support but were able capture in YUV only, so try choosing a different format (eg. uyvy instead yuv).

blackwhite

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: USB camera UVC error
« Reply #4 on: February 22, 2017, 01:15:10 PM »
Hello,

I am also having problem with USB camera on RK3188-SOM-EVB. When try to use it with opencv I am getting these errors and camera is not opening at all.

libv4l2: error dequeuing buf: invalid argument VIDIOC_DQBUF:invalid argument
[ 6441.310330] uvcvideo: uvc_dequeue_buffer is timeout!!

When I run it with luvcview it only works at 2-3 fps which is incredibly slow and also giving this error:

libv4l2: error dequeuing buf:success

Has anyone got solution for that?