Olinuxino Maxi unable to resume from suspend

Started by swahren, May 24, 2016, 01:19:00 PM

Previous topic - Next topic



i'm using i.MX233 OlinuXino MAXI Rev B with a SD card based on this instructions:


Linux version (hehopmajieh@hehopmajieh-office) (gcc version 4.7.1 20120421 (prerelease) (GCC) ) #11 PREEMPT Mon May 21 10:27:52 EEST 2012

After triggering suspend i'm unable to resume the board via recovery pads

root@olinuxino:/sys/kernel# pswitch goto suspend
PM: Syncing filesystems ... done.
Freezing user space processes ... (elapsed 0.01 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
Suspending console(s) (use no_console_suspend to debug)

I've have found this old thread but there wasn't any solution:

Can anyone reproduce this issue or know a solution?


I can confirm that I have reproduced this in the past.
Never really solved it under Linux, but I think some work was done in this area in newer kernels.
All my Olinuxino boards are packed away, and I don't have suspend/resume buttons on my custom board.


Hi Kean,

thanks for cofirming. Unfortunately the Mainline Kernel doesn't provide real suspend support for i.MX23 (only WFI). I tried to port the code, but i stuck at switching CPU PLL to XTAL:


Doing the same on a i.MX28 board everything is fine. I'm not sure if this is CPU, package or board related issue.

So i tried the vendor kernel 2.6.35 which shows the same behavior. But i never tried to setup this old kernel sources with bootlets to verify in the depth.

Btw you don't need the buttons to test suspend/resume. Simply call:

echo mem > /sys/power/state

But you will need no_console_suspend=1 in kernel cmdline in order to wake up from console.

Just one question: do you know the revisions of your olimex boards?


As I mentioned, my Olinuxinos are all packed away somewhere, but I think they're about 2012 vintage if that helps.  Rev B comes to mind, but not sure if that was for the micro or maxi boards.


Awesome! Thanks for all the work you are putting into mxs!


Thanks Stefan!
I've just got back into testing recent kernels on my custom imx233 board.