A10 LIME I2c

Started by charlieholimex, August 18, 2016, 03:32:14 am

Previous topic - Next topic


I am trying to get i2c working on A10 LIME with the official Debian image.

I have an oscilloscope connected to GPIO 1 pins 34 and 36, looking for activity.

I have /dev/i2c-0 through 3

I have four sym links inside /sys/class/i2c-dev, e.g.
lrwxrwxrwx  1 root root 0 Aug 17 17:25 i2c-1 -> ../../devices/platform/sunxi-i2c.1/i2c-1/i2c-dev/i2c-1

I see no activity on the scope when I do
i2cdetect -y 0
i2cdetect -y 1
i2cdetect -y 2
i2cdetect -y 3

I would expect to see at least a burst on SCK when I do one of those (in this case, i2cdetect -y 1)

I have tried modprobe i2c-dev

At this point, I am ignoring the i2c device I am trying to connect, merely looking for a burst on sck.

I have tried writing a little python program using smbus, and using pyA10Lime i2c. Each of those produce Error 70 Communication Error, and no burst on the scope.

What steps am I missing?


Hi, Charlie!

Here you can see a simple I2C demo for A10-OLinuXino-LIME and MOD-IO2 with both program and using I2C tools. But since in the demo I use A10-OLinuXino-LIME-UEXT to connect the module to the host board I2C-2 is used (GPIO1, pins 30 (PB21) and 32 (PB20)). In the README.md you can see more details.

Stan, Olimex
May the Source be with You!