Error booting from SD card

Started by dukenukke, October 02, 2016, 11:49:16 am

Previous topic - Next topic

Which CPU you'd prefer to use in a new design:

iMX233
1 (50%)
iMX28
1 (50%)

Total Members Voted: 2

dukenukke

October 02, 2016, 11:49:16 am Last Edit: October 02, 2016, 07:35:02 pm by dukenukke
I've repaired my Olinuxino maxi (after it was damaged by high voltage on the CPU pin) by replacing the CPU. After that it stops booting from the SD card. I got this message on the debug port:
0x8020a007
according to "IMX23 ROM ERROR CODES" document it means the following:
#define ERROR_DDI_SD_CONFIG_BLOCK_NOT_FOUND
I'm aware of the bug 2229 in TA4 silicon (http://www.nxp.com/files/dsp/doc/errata/IMX23CE.pdf) , so I use 1G and 512Mb cards for booting. I'm also pretty sure that cards are bootable, because I was able to boot Olinuxino before it was damaged.
Additional info:
1. SD-card voltage - 3.12V
2. 24MHz crystal running correctly
3. System type on SD-card - OpenWRT
So, the question. Do I need to make some preparations to make iMX233 bootable from the SD card (by JTAG or something else)?

Kean

Yes, you will need to configure the iMX233 OTP fuses if it was replaced.  You can do this over USB via some special test pads on the Maxi board (the USB bus connecting to the LAN9512).  The process and is decribed in the Olinuxino manual under the section "Using Bitburner".

I'm assuming you haven't adjusted the boot mode jumpers, and that the rest of the board isn't damagaed.

Kean

dukenukke