July 21, 2024, 06:35:03 AM

Issue in isp olimex lpc2378

Started by sachindhiman, July 20, 2015, 09:45:27 AM

Previous topic - Next topic


I am using olimex lpc2378 sdk and want to program the board using ISP via flash magic utility.

But this is not going to happening.
I tried as per following ...

Device LPC2378
Osc value 12 mhz
Baud rate 9600

Jumper rst and isp are closed.

I am confident  that communication between board and host is fine.

I tried open the board by pressing reset button and release it after clicking start button in flash magic gui.
It shows error that signature mismatched. But I have given correct device.

Please provide some hint.




Hello Sachin,

To be able to use Flash Magic with LPC2378-STK you need to set the board jumpers in correct positions first. Please set the respective jumpers in ISP_E and RST_E positions. Then plug the RS232 cable in connector RS232_0.

We now open Flash Magic, the settings are:

Select Device: LPC2378

COM Port: the number which our COM port cable is connected to (for example COM1, we can check in "Windows Device Manager" which is the correct COM number)

Baud Rate: 115200 (you can also use lower)

Oscillator (MHz): 12000

To test the connection you can select the ISP menu and attempt to "Read Device Signature".

Best regards,
Technical support and documentation manager at Olimex


I have exactly that same problem. I did everything recommended. ISP_E and RST_E Jumpers are closed. Baud, com port, device and speed are set. When i click the start button on flash magic, board resetting itself but upload dont start. Flash magic says "connection problem" or "unknown signature".