DUINO > MAPLE

linux ./dfu-util -l returns empty

(1/2) > >>

andrewg:
hi all, need help

powered up a newly bought OLIMEXINO-STM32

installed the maple IDE and dfu-utils (i've tried both using stock dfu-util from the IDE package and recompiled dfu-util from source (http://dfu-util.sourceforge.net/)

then on the command line run:

> ./dfu-util -l
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

-----------
returns nothing - OLIMEXINO-STM32 is not detected as a DFU device

what is wrong?

i've tried "perpetual bootloader" as documented in:
https://www.olimex.com/Products/Duino/STM32/OLIMEXINO-STM32/resources/Olimexino-STM32_Installation.pdf

the device is in slow blinks from the start at power up/boot and after the "perpetual bootloader" steps it is still the same.
and dfu-util -l returns nothing. (there are trouble installing the sketch via the IDE, but i'd guess this symptom is closer to the source of the problem)

note that
> lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 058f:6364 Alcor Micro Corp. AU6477 Card Reader Controller
Bus 003 Device 008: ID 1eaf:0004  << yup maple OLIMEXINO-STM32 is connected
Bus 003 Device 003: ID 2687:fb01 
Bus 003 Device 002: ID 2516:001f 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

LubOlimex:
Hey,

Each OLIMEXINO-STM32 board is tested and programmed with Maple IDE after assembly. It is quite likely something at your side, since setting MAPLE IDE is not a very straight forward task.

Did you adjust the USB permissions? Did you follow the installation instructions here: http://docs.leaflabs.com/static.leaflabs.com/pub/leaflabs/maple-docs/0.0.12/maple-ide-install.html#linux

Unfortunately, MAPLE IDE is a completely dead project now, and some of the installation instructions might be outdated.

Best regards,
Lub/OLIMEX

andrewg:
thanks for the quick response! :)
it isn't permissions, i did sudo ./dfu-util -l (i.e. root permissions) and it returns empty as well.
i'd try setting it up in windows with the driver another time.

LubOlimex:
Hey,

I meant udev rules. This grants permissions to Maple IDE or other software tools to access the board via the USB port. Maybe check here also:

https://github.com/rogerclarkmelbourne/Arduino_STM32/wiki/Using-a-generic-stm32-board-on-linux-with-Maple-bootloader

Best regards,
Lub/OLIMEX

JohnS:
It could be as simple as -l not working but as this is essentially dead software you probably need to get the code and read it then debug whatever is wrong.

John

Navigation

[0] Message Index

[#] Next page

Go to full version