Welcome, Guest

Author Topic: A10 MALI. Current situation?  (Read 2003 times)

johnfulgor

  • Newbie
  • *
  • Posts: 9
  • Karma: +1/-0
A10 MALI. Current situation?
« on: July 05, 2016, 10:59:06 AM »
Hello all,
I've searched a lot over the network, and make several experiments on the latest Debian image, but I was not able to answer to this simple question:
Is the mali hardware acceleration working on not?
On the latest debian image, all components seem to be installed, but when I run eglgears, it seems to look for a missing lima driver. On the contrary, there's a post here boasting 150fps... So, can someone cast some light? I'm sure am not the only people interested in this.
Thank you very much.
Have a nice day

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1713
  • Karma: +43/-2
Re: A10 MALI. Current situation?
« Reply #1 on: July 05, 2016, 03:25:10 PM »
The hardware acceleration video and image decoding is handled by CedarX. CedarX is working. However, not all video players work with the VDPAU drivers. First update and install some player, for example, mpv and then try with the following commands as super user:

export VDPAU_DRIVER=sunxi
mpv --vo=vdpau --hwdec=vdpau --hwdec-codecs=all test.mp4
, where test.mp4 is the video file name

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

johnfulgor

  • Newbie
  • *
  • Posts: 9
  • Karma: +1/-0
Re: A10 MALI. Current situation?
« Reply #2 on: July 06, 2016, 09:59:27 AM »
Hello Lub,
thank for your reply; but I'm speaking about the 3D acceleration. This is not the same thing, right?
Thank you