[IMAGE] A13(-WIFI) Debian (now Ubuntu) + xfce flashable (Updated: 08 Mar: R18)

Started by jwischka, December 17, 2012, 06:36:15 AM

Previous topic - Next topic


Quote from: atal on January 18, 2013, 02:50:56 PM
Thanks for your fast reply. We tested R4 with same troubles yesterday.

I would suggest trying to log in as root, but I've forgotten the password (at least, I'm not sure enough to know without testing).

You might see if you can chroot from a Linux box to the card, then create a new user.

It sounds like the login is succeeding, but then rapidly returning you to the login screen. Do you have a network connection? If so you could try to vnc into the board, or ssh. Can you see if you get the same result from the UART console?


OK, I tried your suggestions. At first I tried to connect via Putty (we have LAN adapter) - no response. Then I modified the forgotten password for root manually in password and shadow file. Same behaving after login root attempt - quick flash of text and login screen showed again.

For complete info our configuration: A13, USB mouse, USB keyboard, LAN adapter, WiFi module on board, 12V power, VGA monitor, 4GB SDcard.

For today it is finish, have a nice weekend.


What happened with the official (Olimex) image on SD card?

Note: has different username/password when you try it!


Quote from: jwischka on January 17, 2013, 05:08:14 PM
Quote from: drspastic on January 17, 2013, 04:44:43 PM
hi, and thanks for all the good work.

may i request you post a .zip of the root filesystem (with any details of swap, other needed partitions.

this will avoid the need to keep flashing cards with dd when the boot partition is already there.
i am getting problems with flashing, maybe wear.


I'll see what I can do. FYI, SD cards have built in controllers which should control the wear leveling issue, and in any event, cards are, for the most part, supposed to be able to experience thousands (or more precisely tens of thousands) of write cycles before failing. What issues are you experiencing, exactly?

the problems i have are cards writing ok a few times then refusing to complete dd with i/o error. im using sandisk and trancsend cards in various adapters. always get very warm on dd.

also my reason to want to download rootfs is its faster and easier unless a user is inexperianced in using gparted etc. also there is no point rewriting an identical boot sector.

by the way i just blew your v4 image to a 8gb sandisk HC card and it booted faster than any image yet. pity i just logged on here and found there is already a v5. now downloading that. pity v4 didnt have any of the wifi tools installed. have you considered using the madwifi package? it has pretty wide support for many different cards.


I used/tested R5 quite extensively yesterday and found no problems with it at all (very minor issues fixed in less than a minute see P.S.).  What you describe sounds like an exit or Ctr-D equivalent.  Could have any number of causes.  Since you're using the virgin root file system that I've been using, software/configuration issues are mostly excluded.  Have you tried logging in through other means such as a serial port or Ethernet?  Since you made it through the boot process OK, defective RAM or insufficient power are less likely put still on the table.

P.S.  jwischka, regarding your root file system, you may want to include your hostname (debian) with IP address (or any other loopback address) in the /etc/hosts file - makes sudo stop complaining.  Also, now that you made the Ethernet adapter work, it might be prudent to uncomment the eth0 stanza in /etc/network/interfaces.  Finally, as soon as there is an Ethernet connection (wired or wireless), file sharing is likely going to happen, and then I think ntp would be a good idea to install to get the correct time stamps.  Again, all of these were fixed within a minute, so not a problem.


Jwishka..great job :o
Is it posible to ad uvc camera support in your next version?

Today i downloaded all filles discript in the wiki  to compile my own kernel.
Ubuntu is running onmy netbook but compilation faild.
So i have to spend the weekend to figure out whats wrong.

Best regards


Post a few (if need be, many) lines showing what failed.  Someone else may recognise the problem.

I've started building it all, hit some issues but now have them all fixed, in case I can help.

Say which Ubuntu etc you're building on.  I'm using Linux Mint 14 and had to install a few things that slightly surprised me.


Good suggestions, all. I will try to add and put up a new version tonight, though due to (still) having no power, I'm at a friend's house with slow internet. Sigh...

John, I'm building with Kubuntu 12.10.


Uploading new image, should be available shortly.

Added ntp, fixed various things. Upgraded packages. Installed wicd.

Added, hopefully, uvc support via modules in the kernel.

I have to be honest, things were a little weird when I was transferring stuff over to the card, and as I don't have my board with me, I wasn't able to test. So this might not work. Or it might. As always, use at your own risk.

Madwifi is going to be more than I want to mess with tonight, so that will have to wait until a later build. Likewise with a rootfs, I'll need to develop a good procedure. Of course, with this, there are kernel updates, so a rootfs isn't all that you need. Besides, you could always mount the image, since you know the card geometry.

At any rate, once things are up I will update this post and OP with a link - I have no idea how slow this internet is, so it could be in the morning. Yay DSL.

Edit 1: GASP! 6 hours. At home it takes about 16 minutes... sigh...


Recommended update for all users: R7

Recompiled kernel / uboot. We now can actually *use* all (or almost all) of our 512mb of memory, which is clever. There is still some reserved for the Mali, but we're talking ~480 usable, which is a lot better than before. Seeing as how I/O wait is such a performance issue this should speed things up considerably.

You can get the image here


Not to keep posting, but....

Is there any interest in a headless version of this? Meaning a kernel where there is no support for the Mali? Even with the Mali modularized, it's still taking about 32MB of memory, which, depending on how you are planning on using this thing, could be better used to do things like increase performance. I personally only interact with the board via VNC/ssh, so I would prefer the extra memory, but it seems that most of you interact via VGA/LCD. Thoughts?


For ease of testing mine is headless.

Also, might reduce what's going on and who knows might even boot!

I've built U-Boot with md5sum support and can see the kernel is loaded correctly from my SD card so it's not the card to blame for the failure to boot.  Progress!

Looks ever more like a hardware fault.



I'll package / upload a headless kernel for you to test... will pm link. If it doesn't work, I have an idea about disabling swap emulation, since that's around where it seems to fail on your board. We'll see, I suppose...


Thanks, Jeff.

I have a kernel built (as in, the make ran quite a long time and went OK) but diverted to U-Boot to get md5sum in.  Kernel and testing "soon" but I'd be pleased if you can do one as my first may well not work LOL